Why is the 'Run from here' command not enabled in my test?

I’m attempting to execute a test from the middle of the test but the ‘Run from here’ command is not enabled. I have opened my test and right-clicked on the line that I want to begin my test from. But the ‘Run from here’ command is greyed out and I’m not able to click it. What am I doing wrong?

You must have a browser instance that Katalon has already generated in order to use the “Run from here” option. An easy way to do this would be to put a breakpoint in your script right after the WebUI.openBrowser() step and run the test in debug mode, then kill the current test, then try right-clicking and Run from here.


Yep, that worked. Thanks. I’m new to Studio so still learning my way around. Appreciate the help.

1 Like

No problem, and welcome!

I have a follow-up question. According to the Katalon docs (https://docs.katalon.com/katalon-studio/docs/execute-a-test-case-or-a-test-suite.html#execute-a-test-case) you should be able to use ‘execute/run from here’ as long as there is an active browser instance that Katalon generated.
I ran a test case and made sure the browser did not close. The option is not selectable as described above. Is the manual outdated or am I missing something?

You are missing this Katalon Studio 7.4.x Releases