Weird behavior for scheduled tasks in Windows

Hello, I have a weird problem when I use Task Scheduler for running Katalon tests. I built a CMD command, set it in Task Scheduler and everything worked fine for few days, but suddenly (there was really no change) it stopped working. It says:

_Test Cases/MyTest FAILED because (of)
org.codehaus.groovy.control.MultipleCompilationErrorsException: startup
8: unable to resolve class myPackage.MyKeyword @ line 8, column 1.
import myPackage.MyKeyword

1 error_

/bin/keyword/myPackage folder’s content is deleted when I attempt to run a task - so those classes cannot be found. But I don’t know why. When I run the same command in cmd line, it works as expected (I run it with the same user).

Do you know what might happen? It is really weird (on other machine, scheduled task works well, but don’t know how long). I use latest Katalon 5.2


There’s a workaround to wrap Katalon command into PS script and run “wrapper” script instead, but I am still curious about the original problem. As I said, it stopped working when I was not at PC.