WebUI.refresh() throws NoAlertPresentExeption in FireFox

Hello i just started using Katalon this monday and i ran into the problem that the Testcase i build fails after the login to the Website. I need to refresh the page to verfy that the login was succesfull (noalertshould be present after the relode) but refreshing throws a NoAlertPresentExeption in FireFox (same with NavigateToUrl). I gues that the login was succesfull i mean there is no error when trying to refresh but the test wont finish and therefor the browser wont close and i cant start with other test with this not working.


Test Cases/LoginVerify FAILED because (of) Unable to refresh page (Root cause: org.openqa.selenium.NoAlertPresentException: No modal dialog is currently open
Build info: version: ‘3.7.1’, revision: ‘8a0099a’, time: ‘2017-11-06T21:07:36.161Z’
System info: host: ‘DESKTOP-5MCE4DS’, ip: ‘’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_181’
Driver info: com.kms.katalon.core.webui.driver.firefox.CGeckoDriver
Capabilities {acceptInsecureCerts: true, browserName: firefox, browserVersion: 61.0.2, javascriptEnabled: true, moz:accessibilityChecks: false, moz:headless: false, moz:processID: 10296, moz:profile: C:\Users\martin\AppD…, moz:useNonSpecCompliantPointerOrigin: false, moz:webdriverClick: true, pageLoadStrategy: normal, platform: XP, platformName: XP, platformVersion: 10.0, proxy: Proxy(direct), rotatable: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}}
Session ID: 8515807b-1a48-4cc1-b4ae-39579c0c0c38)

Test Cases/LoginVerify run:45

Try to add:

Before the refresh. It might just be going to fast.

I have done that already and it didn’t work for me thats why i asked. But thanks anyway.

Hmmm could I see the code you have in katalon?
Did you also try this in other browsers?
What version of firefox are you running?

imoprts *

autoit_prj = ‘C:\\Users\\Martin\\Desktop\\Tests\\loginToWebsite.exe’
WebUI.refresh(FailureHandling.STOP_ON_FAILURE) <- This is where FireFox is failing and giving me the error.

Firefox: 61.0.2

In GoogleChrome and InternetExplorer it workds fine.

Sorry for late response. Have you tried to take out the error handline and just do a