This is a companion discussion topic for the original entry at https://store.katalon.com/product/120#qa-content

So I tried to download and install this plugin. However, it does not appear to have ‘downloaded’ ? Katalon says it is installed, but I do not see anything in my Plugins folder or any ‘CustomKewords’ files as the sample test shows.

Any help would be great. thanks

there is any particular reason to open two discussions on this forum, with same content?
please decide which one do you track and discard the other one

Sorry. No, I guess this one since it is for the Plugin discussion. Just didn’t know if there was a better place to get visibility.

I did some more looking around, and I think I found it. It was installed into my Katalon Folder under: \configuration\plugin\install\223113\2.0.0 (not the ‘Plugin’ folder as I expected.

Now my issue is how to use this plugin. the sample test/code seems to run but the socket.reply is null. and not sure what methods I can use or apply as there doesn’t appear to be any auto-complete methods to choose, and no file/documentation to suggest what is available.

In the GitHub, I found the following public repository:

Perhaps this is the source, but I am not sure.

The sample Test Case “SampleWebSocketTestcase” tries to connect to the destination URL ws://echo.websocket.org. I tried to run this test case but failed.

I tried to find how is “echo.websocket.org”. I got the following screen replied:

Perhaps this Katalon Plugin is no longer maintained. But you can read the souce at GitHub and learn something out of it.