WebElement Exception error

I am getting this error when I verify this element in web object spy, It is verifying it correct. But when I run this test it fails. Anyone able to help me to run this test, would apprecialte.

Unable to click on object ‘Object Repository/Single Login/Main_Menu_Test Folder/Page_Add User/button_Submit Changes’ (Root cause: org.openqa.selenium.WebDriverException: unknown error: Element … is not clickable at point (952, 538). Other element would receive the click: …
(Session info: chrome=70.0.3538.110)
(Driver info: chromedriver=2.35.528161 (5b82f2d2aae0ca24b877009200ced9065a772e73),platform=Windows NT 10.0.16299 x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 0 milliseconds
Build info: version: ‘3.7.1’, revision: ‘8a0099a’, time: ‘2017-11-06T21:07:36.161Z’
System info: host: ‘FPFZNH2’, ip: ‘’, os.name: ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_102’
Driver info: com.kms.katalon.selenium.driver.CChromeDriver
Capabilities {acceptInsecureCerts: false, acceptSslCerts: false, applicationCacheEnabled: false, browserConnectionEnabled: false, browserName: chrome, chrome: {chromedriverVersion: 2.35.528161 (5b82f2d2aae0ca…, userDataDir: C:\Users\BVISWA~1\AppData\L…}, cssSelectorsEnabled: true, databaseEnabled: false, handlesAlerts: true, hasTouchScreen: false, javascriptEnabled: true, locationContextEnabled: true, mobileEmulationEnabled: false, nativeEvents: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: XP, platformName: XP, rotatable: false, setWindowRect: true, takesHeapSnapshot: true, takesScreenshot: true, unexpectedAlertBehaviour: , unhandledPromptBehavior: , version: 70.0.3538.110, webStorageEnabled: true}
Session ID: 92a3ae62df260fda8570b42563ee1626)

Did you try searching?



I did. I also tried WebUI.verifyElementChecked(Test Object, timeout) and no luck.
When it can find and verify the element in the web spy I am not sure when we run the test it is not able to able to find the object to click on

My guess is, something is getting in the way of the automated click – that something is not present when you’re using the spy tool.

In your test, try waiting until the element is visible. You might also wait until it’s clickable. You might also add a short delay after that.

Reasoning: automation is SUPER FAST… much faster than a human reading the page, deciding what they need to do, then doing it.



Thank You Russ,

I will give it a try.

Omg. It actually worked :slight_smile:

Thank you again. I have been with this issue since friday :frowning: