Web Recorder and Object Repository issue


I have a setup where my Objects are 2 folders deep:


In the latest release the web recorder is not creating the script with the proper path to the objects causing the newly created test to not work unless I manually correct the path.

I have tried multiple options for letting the recorder create the objects inside the desired folders.

Please resolve this bug so that the recorder creates the script with the proper directory structure multiple layers deep. Thank you

Step By Step:

I tried not letting it create the folders and selecting the folder it needs to be in which becomes SalesApp/pageā€¦/OBJECTHERE

Then also tried letting it keep the folders and starting from SalesApp

The tool then creates the following Script which fails on any attempt to run it. Notice the SalesApp is missing.

Then if I manually add the SalesApp/ prefix the script is able to run successfully.

Screen Shot 2018-11-01 at 9.08.22 AM.png

Screen Shot 2018-11-01 at 9.08.37 AM.png

Screen Shot 2018-11-01 at 9.09.41 AM.png

Screen Shot 2018-11-01 at 9.13.18 AM.png