Version 6.3.0 (Beta)

@duyluong
On first look it seems the object parametrization is back to expected behavior on KS 6.3.2

Thank you for the quick solution.

Thanks @duyluong. Yes It could be the case because i updated it from 6.2.2 version.

Mobile.verifyElementNotExist when element not exist while throw SteFailException.
According to the API description, i think true should be returned

Am getting memory issue problem in(v 6.3.2). When am running Console mode Katalon Studio v 6.2.2 i didn’t face this issues after upgrade only am facing this issue

In Ubuntu 18.04 :-

My system total memory is 4GB if i run katalon studio with test suite contains 10 testcases after 8th test cases we are getting issue as “java.lang.OutOfMemoryError: Java heap space”

In Windows 10

My system total memory is 8GB if i run katalon studio single testcases also it will hang and sometimes Browser won’t open please support us to solve this problem

Bug 179# Proxy configuration needs exclusion list - has been added to your product backlog. In which release are we targeting this fix. This defect is blocking many of the corporate as most of them have proxy where Intranet sites are in exclusion list.

Hi! The report generated from an execution is located in: Project/Reports/TimeStamp/TestSuite/TimeStamp/Report files… but in version 6.1.5 was located in: Project/Reports/TestSuite/TimeStamp/Report files.

Does anyone else have the same problem?
I’m using the Basic Report plugin.

Regards.

1 Like

test data with multiple lines is return with redundant character quote (’)

image

please help, how to show the report folder
Screenshot_1

Download this plugin

I installed the plugin, but the report folder still doesn’t appear

You can find the report in the Test Suite View in the results tab.

Or you can go to the Project folder, you will find the report folder.

Do the behavior of WebUI.clickOffset() changed? I have several tests that were written prior to 6.3.0 and worked with a certain set of coordinates. Now, those coordinates result on clicks on different parts of my object, which ended up breaking all my tests. I’ve done a little testing and figured that the (0,0) is now the center of the object (which would imply in the use of negative coordinates to move the clicking point to the left and to the top), not the top-left corner as before (and as stated in the documentation). Is that intentional?

@gabrielpflores

That doesn’t seem intentional to me, are you positive that this behavior starts appearing in 6.3.0 ?

Tbh I’m not 100% that this started to happen on 6.3.0. I upgraded to it a couple of days ago, most precisely to 6.3.2. Prior to that I believe I was using 6.2.2 and I do not recall seeing this behavior, my tests were behaving fine.

Anyway, the documentation says that the input coordinates should be relative to object’s top-left corner. But if the input coordinates are (0,0) the click is going to happen exactly in the middle of the object (tested on a canvas element), instead of happening at the top-left corner of the object.

I noticed a test wasn’t clicking on a timeline with offset correctly around mid-June of this year, I’m not sure what version I was using at the time or when it initially started to happen. To fix the issue, I had to subtract the width of the element divided by 2 to the offsetX parameter and it seems more stable so far. I recently noticed in the console logs when I use clickOffset() that this message is displayed:

“Aug 26, 2019 2:32:24 PM org.openqa.selenium.interactions.Actions moveToElement
INFO: When using the W3C Action commands, offsets are from the center of element”

But the Katalon docs and keyword explorer both claim that it is from the top-left corner of the element

-Thanks

Yes same issue happening with me. I was not sure that it was happening due to Katalon version upgrade to 6.3.0 or Chrome version upgrade to 76 because I upgraded both at the same time. But now It is clear from discussion that it is due to Katalon version upgrade to 6.3.0. For me the workaround is clicking directly on element using JavaScript. But ClickOffset was working perfectly in 6.2.2

Does anyone know if the latest Katalon version fixes this bug: Katalon Studio freezes and non-responsive ?
Version 6.2.2 still has this bug.

@Lukas_Boekenoogen why don’t you simple try it? keep a previous known-to-work version for safety

Hi there!

Katalon Studio version 7.0.0 is enhanced to reduce memory consumption by adding some JVM options.

Please first check out the release note and click here to download if you want to try out version 7.0.0 (beta).

Cheers

Jass

Hi,

From release 6.3.0 a have noticed huge difference in performance of Test Suites. Test cases that normally run for about 2m 30s are now runnig for more that 3m. This problem is more noticable in my test suite collection where normall speed 3h was replaced with more than 5h duration. I have tried every other version and the problem seems to be getting even worse. For example its 7m in Katalon 7.0.0 for my test case. It seems that longer the Test Suite Collection is the slower the execution will become.

My computer is meeting minimum requirements and all my project data are stored locally.

I have tried to set up my proxy confguration to be off and to be set by system but nothing helped.

Is there any way to fix this issue ?
Thank you for your answer,