Unable to start app at the desired location-Android Mobile

For the past few weeks I am just struck with this error when running my sample test case in Katalon - Android Mobile Testing. Can anyone please help.

Please find the attached image.

Hi @janani0515,

Can you confirm what versions of Katalon Studio and Appium you’re using? For best compatibility, it’s recommended that you use Katalon Studio 6.1 with Appium Server 1.8.1.

Here is some more info on troubleshooting common issues:

Hope this helps,


Hi Chris_Trevarthen,
Thanks alot for the assistance.Please find the below versions of applications.

Katalon Studio - 6.1
Appium - 1.8.1
Unfortunately when I try to install appium 1.8.1, it is getting hanged up in the middle.
Please refer attached image.

Hi @janani0515,

If you’re having trouble installing Appium via the command line, i.e. npm install -g appim@1.8.1 you can try a couple of things:

  • Reinstall Node.js (I’m using 11.10.1)
  • Install Appium Desktop 1.6.3 (it includes Appium Server 1.8.1) You can find the installer at: https://github.com/appium/appium-desktop/releases/tag/v1.6.3
  • Make sure you have the Android emulator started before the test starts (this is probably true, but a good thing to check)

Hope this helps,


Hi Chris_Trevarthen,
Thanks alot.I succeeded in installing Appium 1.8.1 however the same error occurs and it is quite saddening!!

I am trying to use a real time android device rather an emulator.

Error Message :

2019-04-09 20:44:08.815 ERROR c.k.katalon.core.main.TestCaseExecutor - :x: startApplication(appPath, false) FAILED.


com.kms.katalon.core.exception.StepFailedException: Unable to start app at: ‘C:\Users\EG-GM\Katalon Studio\SampleTestMobileProject.prj\androidapp\APIDemos.apk’

at com.kms.katalon.core.keyword.internal.KeywordMain.stepFailed(KeywordMain.groovy:48)

at com.kms.katalon.core.mobile.keyword.internal.MobileKeywordMain.stepFailed(MobileKeywordMain.groovy:40)

at com.kms.katalon.core.mobile.keyword.internal.MobileKeywordMain.runKeyword(MobileKeywordMain.groovy:23)

at com.kms.katalon.core.mobile.keyword.builtin.StartApplicationKeyword.startApplication(StartApplicationKeyword.groovy:51)

at com.kms.katalon.core.mobile.keyword.builtin.StartApplicationKeyword.execute(StartApplicationKeyword.groovy:40)

at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:56)

at com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords.startApplication(MobileBuiltInKeywords.groovy:74)

at com.kms.katalon.core.mobile.keyword.MobileBuiltInKeywords$startApplication.call(Unknown Source)

at Verify Correct Alarm Message.run(Verify Correct Alarm Message:24)

at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)

at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)

at com.kms.katalon.core.main.TestCaseExecutor.runScript(TestCaseExecutor.java:331)

at com.kms.katalon.core.main.TestCaseExecutor.doExecute(TestCaseExecutor.java:322)

at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(TestCaseExecutor.java:301)

at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(TestCaseExecutor.java:293)

at com.kms.katalon.core.main.TestCaseExecutor.execute(TestCaseExecutor.java:227)

at com.kms.katalon.core.main.TestSuiteExecutor.accessTestCaseMainPhase(TestSuiteExecutor.java:129)

at com.kms.katalon.core.main.TestSuiteExecutor.accessTestSuiteMainPhase(TestSuiteExecutor.java:112)

at com.kms.katalon.core.main.TestSuiteExecutor.execute(TestSuiteExecutor.java:81)

at com.kms.katalon.core.main.TestCaseMain.startTestSuite(TestCaseMain.java:157)

at com.kms.katalon.core.main.TestCaseMain$startTestSuite$0.call(Unknown Source)

at TempTestSuite1554822798670.run(TempTestSuite1554822798670.groovy:35)

The above error message keeps repeating inspite of changing versions.

Hi @janani0515,

Are you able to try this test on an emulator? I’m seeing a few people have similar issues when trying this on real devices and so I’m wondering if you’d have better luck on an emulator.

– Chris

Hi Chris_Trevarthen,
I am glad to tell you that I finally succeeded in running my test suite after about a month’s hardwork :slight_smile:

I ran the test suite in real device and it worked out finally.Following are my observations, (not sure if these were causing problem).

  1. I turned off my ‘Windows Firewall Security’.
    2.As read in one of the forums, I just set appWaitActivity = *

And this pretty much worked out.
Thanks alot for your kind help and assistance throughout my phase.

N.Aishwarya Janani


Hi Chris_Trevarthen,

I got this message when i run apps: “Unable to start application : … Original error: Error in waiting for device. Original error: 'Error executing adbExec…”

The Specification:

OS: Windows 10 64bit
Katalon Version:
deviceOS: Android
deviceOSVersion: 6.0

But when I Run the sample projet I get this message :

When i try record mobile i get this message:

What should I do?

Thank you,

Hi @Rahadiyan_Koesandria,

Can you please confirm what version of Appium you’re using? You should be able to find this out using the following on your command line:

appium -v

With Katalon Studio, I would recommend Appium Server 1.8.1.

If you want to upgrade to Katalon Studio 6.2.0, you can use Appium Server 1.12.1.

Hope this helps,


Hi @Chris_Trevarthen,
Thank you for your response.
Now, i already used Appium server 1.13.0 version.

then i’ve got the error message:

But, before Appium server 1.13.0 version, i was used appium server 1.8.1 version and got this error message:


What should I do?

Thank you

Hi @Rahadiyan_Koesandria,

I don’t think Appium 1.13 is supported, yet, so I wouldn’t rely on that version. A couple of things you can try:

  • Uninstall and reinstall Android Studio and the Android SDK
  • With your device connected, from the command line, run:
    adb uninstall io.appium.settings
    adb uninstall io.appium.unlock
    Then try to restart the recording process.

Hope this helps,


u r my hero!