Unable to save part: can not change the default value of Variable to Test Case

I made a project to reproduce the problem and published it on GitHub

How to reproduce the problem

  1. open the project with your Katalon Studio
  2. open the test case named Test Cases/main/restorePreviousTSuiteResult
  3. click the Variables tab.
  4. you will find a variable named STRATEGY is predefined. It has type of String. It has the default value of 1hourAgo .


Problem 1 : changed the default value, but the new value is not displayed

I wanted to change the default value of the STRATEGY variable from 1hourAgo to a new value last .

In the Variables tab, at the row of STRATEGY , in the input field of Default value , I typed in the new value last . See the screenshot:


Then I moved the cursor out of the input field. I expected that the new value last to be displayed in the field, of course. Howerver, to my biggest surprise, the input field displayed the old value 1hourAgo .


I thought I need to retype the new value, so I moved the cursor in to the input field of Default value, last came up! The input field knew the new value last but does not show it up. Why? I do not find any rational explanation for this behavior.

Problem 2 : Unable to save part when tried to save the change

I thought the new value last is accepted (though it is not shown up). So I wanted to save the settings into disk. I clicked the Save All button. Then a Error dialog came. It said “Unable to save part”.


I was unable to save the change at all.

1 Like

Hi @kazurayam

I downloaded your project and proceeded to reproduce it but failed. I read your steps again and again and precisely executed them but no errors ever showed up. I could modify the value and save the variable normally.

Well, at least that’s how it is on Katalon 5.10.1. I will try it on the beta versions to see if it’s reproducable.

Just curious. I expected it would be easily reproducible.

1 Like

Thanh To

I am on Windows 7.
What are you on? Mac?

1 Like

Does the Language \ Locale setting matters for Eclipse?

I am on ja_JP

Does IME (Input Method Editor) matters for Eclipse?

1 Like


I am using Windows 10.
The language setting could be a clue, I would investigate this possibility.

On 5th Feb, 2019 I encountered this incident as I reported this to Katalon Forum.

On 6th Feb, 2019 I tried to reproduce this incident. But the incident NOT happend . The value of Default value was happily updated, the change was successfully stored without “Unable to store part” dialog.

Why not? I have no idea.

1 Like

My thought

IME is the clue

I believe that this incident has something to do with IME: Input Method Editor.

But what is IME? The following is quotation from Wikipedia.

An input method (or input method editor, commonly abbreviated IME) is an operating system component or program that allows any data, such as keyboard strokes or mouse movements, to be received as input. In this way users can enter characters and symbols not found on their input devices. Using an input method is obligatory for any language that has more graphemes than there are keys on the keyboard.

For instance, on the computer, this allows the user of Latin keyboards to input Chinese, Japanese, Korean and Indic characters; on many hand-held devices, such as mobile phones, it enables using the numeric keypad to enter Latin alphabet characters (or any other alphabet characters) or a screen display to be touched to do so. On some operating systems, an input method is also used to define the behaviour of the dead keys.

See the following picture. In there you can see IME in action. IM_in_action.png

I work on a PC with Language=ja_JP, so IME is fully functional. But other people who live in English domain are not likely to be familiar with IME because they would never use it. IME is not enabled on their devices.

What is involved for Java application to work with IME

I am not very much familiar with GUI programing in Java. I wanted to learn how to write a Java program which displays Window using Eclipse SWT API, accept input/output in a IME-enabled text field.

By a quick search I found the following page provides a handy sample code: Java2s.com : Add focus in/out event to Text : Text Event « SWT « Java Tutorial

What is happening on the Variables tab for Test Case in Katalon Studio?

The above sample code has the following fragment.

t2.addListener(SWT.FocusOut, new Listener() {
  public void handleEvent(Event e) {
   System.out.println("focus out");

SWT Text object needs a Listener object registered for the SWT.FocusOut event. The SWT.FocusOut event is fired when I move the cursor out of the IME-enabled input field to somewhere outside of it.

I guess, Katalon Studio has a small shortage. It does not implement the Listener for the SWT.FocusOut for the input fieds, or the implemented Listener is incomplete somehow. .

Just I guessed so.


I checked version 6.1.0 and found this issue still remains.

1 Like

I encountered exactly the same problem in version 5.10.1 and 6.0.5. I downloaded a new version yesterday and the problem seems to have gone away. The issue is intermittent and happens very often for versions 5.10.1 and 6.0.5. Is this issue resolved by Katalon team?

I have to use Katalon more to confirm this issue is resolved.

How did you get it? URL?

1 Like

I downloaded the version 6.1.1 as announced by the following post.

I tried it and found the “Unable to save part” issue was fixed in it. I am no more annoyed. So glad.

1 Like

kazurayam, glad to see you have the problem resolved in the new version!

Not yet fixed?

1 Like