Unable to run Scripts on Emulator

Hi, I am trying to run the script on Emulator and the same is displayed under Mobile Recorder. After scripting, I am trying to run the script. But Nothing is happening when I run.

Please help

@Chris_Trevarthen @duyluong

Hi @sudheer.dj,

Please show screenshots of Job Progress view (on the right side), Log Viewer.

@duyluong , please see the attached screenshot

@duyluong any update?

Hi @sudheer.dj,

Please share a recorded video when running Android execution and the Error Log file.

@duyluong here is the screencast. https://www.screencast.com/t/rRhUSHRVPZg0

Hi @sudheer.dj,

Please also share the Error Log file by clicking on Help -> Error Log

Please find the log.

Log.zip (27.6 KB)

Does this happen if you run with another Execution such as Chrome, Firefox?

@duyluong when I run with chrome, it successfully runs.
But this is actually an Android Project and I am trying to run it on an Android phone

Do you have any Desired Capabilities in Project Settings/Desired Capabilities/Mobile/Android?


If I run with the Real device, I am able to run successfully

Please share [your-project-location]/settings/internal/com.kms.katalon.core.mobile.android.properties file

com.kms.katalon.core.mobile.android.properties.zip (744 Bytes)

I see Device Id. That is the id of my real device. Previously i ran with that mobile. Now i have removed it and trying to run on the emulator. But still, it stores the old device id

I think you should manually replace the file content with this then reopen project and run again:




@duyluong do we need to change everytime while changing the device?
Katalon should actually detect and update the device id right. Mobile recorder automatically detects the device right.