Unable to open an app using the application ID where it throws an 'org.openqa.selenium.sessionnotcreatedexception' error

Unable to open an exisiting app using the application ID where it throws an ‘org.openqa.selenium.sessionnotcreatedexception’ error.
I even tired all the following that you mentioned previously in the community:

  1. Tried to debug the Appium log file.
  2. Also, tried to launch the application using the application ID instead of the APK file.
  3. Updated the latest stable chrome driver.
  4. Tired to uninstall the adb files.
  5. Tried to delete the andriod_sdk files and installed it directly via Katalon by clicking the Spy device option
1 Like


It is sad to hear that none of the above workaround did work. Can you please give us the full error log? As the root cause behind is different

Hi Katalon,

It’s fantastic that you guys read my comment. I have resolved the issue. There was a mismatch in the npm and node versions. So, I uninstalled and updated it. Also, after updating Katalon to the latest version, it’s working fine now. Sorry that I also lost the error log. I’ll come back if I face the same again. Thanks again.

1 Like