Unable to capture objects, Reasons: SWTException


#12

Chris Trevarthen said:

Mathias,

OK, I started getting the SWTException as well, but in Android, so I think it’s related to the Katalon tool itself. It’s going to sound annoying, but I was able to get past it by quitting the emulator/simulator, quitting Katalon Studio, and restarting my computer. After that, things started working again.

- Chris

I am also observing the issue with below versions -
Appium 1.8.1
Katalan 5.7.1.

I’ve restarted machine but no luck

IssueKatalon.png


#13

Hi chandramouli,

Usually, the SWTException is thrown by Katalon or the underlying Eclipse IDE on which it’s built. In my experience, there’s not much that you can do to fix this, other than closing your project and restarting Katalon, or uninstalling and reinstalling Katalon Studio.

For more info on SWTExceptions.

Sorry I can’t be of more help,

Chris


How to read toast message in android
#14

i have same issue
using Appium 1.10.0
android 5.0.


#15

Hi akrana97,

Katalon Studio (5.10.1 right now) only supports Appium 1.8.1 currently. Can you try downgrading your version of Appium and see if that helps?

To install Appium 1.8.1:

npm install -g appium@1.8.1

EDIT: Katalon Studio 5.10.1 also supports Appium 1.8.2-beta, although you only need this version if you’re testing Xcode10 and iOS12.

– Chris


#16

The above worked for me. Thank you !


#17

Hi ,

open terminal and;
go to >> cd /usr/local/lib/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent

write >> mkdir -p Resources/WebDriverAgent.bundle

write>> sh ./Scripts/bootstrap.sh -d

These ones gonna help to solve your problem.

Good luck!


#18

Hi @Chris_Trevarthen,

I Tried this
EDIT: Katalon Studio 5.10.1 also supports Appium 1.8.2-beta, although you only need this version if you’re testing Xcode10 and iOS12.

Configuration:
Mac Os 10.14.4 (Mojave)
IOS 12.1 (iPad)
appium 1.8.2-beta
Xcode 10.1
Katalon 5.10.1

but katalon not detecting device, Please refer attached screenshot
which version of katalon studio should work with above configuration?

Thanks in Advance.


#19

Hi @chandu.komireddy,

XCode 10.1, iOS 12.1 and appium 1.12.1 are both officially supported in v6.2.0.rc1 in later. Please download at this link: Katalon Studio version 6.2.0.rc1 with experimental support for iOS 12.2 and Xcode 10.2

Katalon 5.10.1 only supports XCode 9.4.1 and Appium 1.8.1.

Thanks


#20

Hi @duyluong,

Thanks for quick response.
Lets try and let you know. and also please share an link contains the version compatibility with Xcode, IO, Appium and Katalon versions.

Thanks in Advance.


#21

Then same here:
Katalon Studio Version: 6.1.5, Build: 3
Appium Version 1.8.1

Message: Unable to capture objects
Reason: SWT Exception

Details: Failed to execute runnable (org.eclipse.core.runtime.AssertionFailedException: null argument:)

Any solution for me?


#22

Hi, @Chris_Trevarthen
I have the same issue…

Unable to capture objects - SWT Exception (for spy mobile)
Unable to capture objects - ExecutionException (for record mobile)

I try to make record/spy mobile on iOS

Mac OS Mojave 10.14.5
Katalon studio version: 6.1.5
Appium v1.13
Xcode 10.2.1

Can you tell us which version of appium/Xcode/Katalon we must use please ?

Thank you


#23

Hi @g.colle,

I’ve had luck with:

MacOS Mojave 10.14.5
Katalon Studio 6.2.0 beta rc1 - Although the official 6.2.0 release is out now, but I haven’t tried it.
Appium Server 1.12.1
Xcode 10.2.1

Hope this helps,

Chris


#24

Hi, How can I downgrade Appium => 1.12.1 ?


#25

Hi @g.colle,

If you’re using Node Package Manager (npm) you can run on your command line:

npm install -g appium@1.12.1

And that should replace the existing version of Appium.

Hope this helps,

Chris


#26

Thanks for your help.

I’ve installed the new version of Katalon + downgrade appium > 1.12.1

But now, katalon don’t found my iOS Device. My iOS Device is well connected to Xcode.

How can I solve this pls ?


#27

Hi Chris,
I upgraded Katalon version. Today I have installed version 6.2.0 cr1 but when I use Mobile Spy i don’t see my real device. What’s the problem? Can you help me?
My version are: Katalon 6.2.0 - Xcode 10.2 - Appium 1.12


#28

Hi @g.colle and @marco.pastore,

This seems like a common problem and there are some troubleshooting steps in this post (and the thread) that might help you fix it:

Hope this helps,

Chris


#29

Hi Chris, I have problem yet. I used the link in top of your response for install v6.2.0.rc5, but when I use the spy mobile function my real device is not visble. In the list I see all xCode simulators and empty line that corresponds with my device. When I run ipa file there is the following error: device missing.
Later for v6.2.0 rc1 I do not see neither an empty line but only simulators list. Can you help me?

More informations: I check if my device is recognized with command idevice_id -l and I have the correct uuid on the terminal.


#30

Hi @marco.pastore,

The empty line shows that there was a problem in libimobiledevice libraries and you need to reinstall them. If you use these commands, the error will show:

ideviceinfo -u <device_id>
idevicepair pair -u <device_id>

Please follow these instruction to resolve your issue:



#31

Hi @duylong,
I reinstalled the library and run command and on terminal I don’t see any error( I attached the log of my terminal). From Katalon, when I use spy mobile function I see always and after run the appium log show my that message: “The mobile device is missing” that I suppose it is relative to first error.

marcopastore$ idevicepair pair -u
marcopastore$ ideviceinfo info -u
marcopastore$ idevice_id -l

Thanks for helps!