Trouble with Katalon Recorder update 5.5.2.4 (pause command)

Hello!
I’ve used Katalon Recorder for a few months. It is very useful. But I have trouble with Katalon Recorder update 5.5.2.4. When I open test suits, blank Target space is filled with “undefined”. Then pause command doesn’t work at all. I tried to delete “undefined”, but it appeared again when I saved and opened it.
Please tell me how to use pause command smoothly.

Hi @kodai.miki,
Would you mind sharing your saved file?

I have the same issue, Pause is not working since the last update.

Are you talking about the Pause button or the Pause command? I can’t reproduce this issue, the pause button and the pause command works fine on my side, please provide more information so that we can see what’s wrong!

It is the Pause command. It waits for a certiain amount of time before executing subsequest actions. I use Chrome browser. The problem came with the last update yesterday.

That’s very weird, I recorded a gif to show that the pause command still works (you can see it’s pausing). Can you provide a gif or something like that would help us reproduce?

I found the issue. Before the update the pause command took the waittime as “Value” and the “Target” was undefined. Now the waittime has to be put as “Target”. This is not logical. Why has it changed?
pic

Hi there, I finally understand, that clears things up. In reality the pause command takes values from both the Target and Value field and if the Target has any value it will use it, otherwise it will use the Value field’s value, but because the target is undefined it gets parsed as 0 and therefore the pause command appears to be not working. Apologize for the inconvenience, we’ll fix this issue ASAP.

Thank you for looking into the matter. Now I will use pause command typing numbers in Target. I’m waiting for fixing.

I also noticed that endLoadVars command was also showing undefined for target recently when I pull test cases from before. I was not seeing this before. I do not if there is an impact to the actual functionality though.

@glenn_remar @kodai.miki @Feelea

We have released 5.5.2.5 that fixes this issue, please see if it resolves the problem.

I was updated to 5.5.2.5 today. For target, I was still seeing undefined for endIf, else, endWhile,
chooseOkOnNextConfirmation, and endLoadVars commands. I will see if it is just a display issue or impacting tests.

I ran tests. Though steps show undefined, the steps ran find for the commands above.

1 Like

@glenn_remar

Can you share your script that’s still encountering the issue (removing all sensitive information). We can’t reproduce it from our side.

Here is an example. image
It did not seem to impact functionality.