Test Suite Execution Taking Too long (was Katalon became useless)

Windows 10 Home, versin 1903 64bit
Katalon Version 6.3.3
Google Chrome 77.0.3865.75

Hello again,

I have super big issue. I can’t use Katalon Studio at all. I can build tests etc but running them is impossible.
I dont know what happened but it all started yesterday. Basicly, launching test suites and test suites collection is impossible. It takes hours to run a test suite when a few days ago it was a few second.
Im attaching a screenshots. First of all, this “Launching test suite” bar is taking super long time to load:

Second of all, when its finally done and test suite is running,results are showing in weird way. Whole test suite is complete but for Katalon it is still on going and its showing results of test cases on by one. See screenshot:
Uplouding reports to Katalon Analytics is not working as well. Its just keep loading forever and if its not there are 0 passed tests.

I’ve arelady tried reinstalling Katalon, using less occupied project but its still the same issue. I need your help guys

Edited by @Russ_Thomas

Let me assume you have Katalon Studio installed in a directory %KATALON_HOME%, you will find a file %KATALON_HOME%\config\.metadata\.log. Please share the .log file. In there I suppose we can find some errors recorded.

I cant share .txt file. Its not authorised here. I can give you the link : https://jsfiddle.net/nupzjL1h/
Here are all lines from this file

I looked at the shared link. I found no errors recorded. The log looks quite silent.

Looks similar to this:

@wolczoskar Please update your original post with the following information:

  1. Operating System and version.
  2. Katalon Studio version.
  3. Browser and version.

Then try this and report back here:

  1. Close Katalon Studio and UNCHECK “Auto restore this session on next open”.
  2. Restart Katalon Studio and create a new project.
  3. Create a simple Test Case (navigate to katalon.com is enough).
  4. Add the Test Case to a new Test Suite.
  5. Try the Test Suite and let us know the results.

Purpose: We’re trying to find out if the problem resides in Katalon Studio or your project.

  1. Windows 10 Home, versin 1903 64bit
    2.Katalon Version 6.3.3
  2. Google Chrome 77.0.3865.75

I’ve did all steps and indeed it is faster with simple test cases like this. But why it started to happening in my project so suddenly? It was quick and good like 2 days ago and yesterday it was a complete mess and so it is today

That’s good news. Now do this:

  1. Open a clean (no-project) Katalon Studio, just like before.
  2. Open your problem project.
  3. Click the menu File > Clean up...
  4. Try your suite again.

If that didn’t work, do this:

  1. Close Katalon.
  2. Delete the following from your project folder:


  1. Restart Katalon and try again.

Unfortunately, after doing all of this, still test builder takes too much time. And still after running test suites, results of test cases are showing one by one when test suite ended like 10 minutes ago. I dont know what can cause this. Too many profiles? Too many objects in object repo? I’ve deleted unnecessary tests etc.

Last ditch…

Are you using Katalon Analytics? Turn it off/disconnect. See this post.

I just noticed you’re using Win10 Home. Have you searched the forum? Did you see this?

Hi @wolczoskar

Can you share us a video of this happening. I think it may give us some clues about what might be going on.

Here a few questions I hope you can answer:

  • Have you tried to disable KA integration ?
  • Does the problem occur on all types of web drivers or just exclusively on Chrome ?
  • When the Test Suite is launching, does it take long to open up a chrome window, or that the chrome window opens, but it takes a long time to load a page ?
  • Does the problem occur on the Test Suite level only ? Or Test Case executions are also slow ?


same situation happens to me: if integration with Katalon Analytics is enabled: test suit running takes too long and results are not exported to katalon analytics reports. I have tried to disabled integration and then everything works fine. But in this case I’m not able to see tests results in analytics :frowning:

Hello all,
coming back to this. As i said in other topic, Katalon Analytics was the problem. When i turned off integretion with KA everything was back to normal and i can run my test suites normally. I really hope this issue will be fixed soon.
Thanks for all the help

1 Like

Follow up here: Version 7 Katalon Analytics bug collector