Stuck in "NavigateToUrl"

I’m running the Runtime Engine with a fixed machine license.
Sometimes the test run gets stuck in a NavigateToUrl step and times out the server/takes forever.
My only solution so far is to set a maximum time on the test execution on my CI server but that causes another problem.
It seems that when the process is forced killed the next job will fail because of license limit - which isn’t true. Pretty frustrating.

What can I do to stop the test when it gets stuck?

The log is attached: log.txt (73.0 KB)

1 Like

In the log, I found a line:

[16:17:42]W:	 [Step 1/2] 2021-08-24 16:17:42.154 ERROR c.k.k.core.keyword.internal.KeywordMain  - ? Unable to navigate to '' (Root cause: com.kms.katalon.core.exception.StepFailedException: Unable to navigate to ''

Unable to navigate to ''Is this URL correct? Is it present?

I checked if the hostname is known to the public Domain Name System:

$ nslookup

** server can't find NXDOMAIN


This proves that the host is not known to the public DNS. So I suppose that the host name may be wrong.

By the way, the host is known. It is proved as follows:

$ nslookup

Non-authoritative answer:


Your organisation might have a private Domain Name Server which resolves the host name to an IP address in your local network. If it is the case, I think you should check if your private DNS is working stable or not. The failure you got indicates that the DNS is unstable.

No, thats just to hide my test url. The url thats being tested is working fine - and even if it doesnt answer I dont want it to retry for that many minutes.

[16:17:42]W:	 [Step 1/2] Caused by: org.openqa.selenium.TimeoutException: timeout: Timed out receiving message from renderer: 299.860

Taking this message as a key, I goodled and found the following thread:

I was able to isolate the issue. In my case it was happening only for pages referencing a static file (an image in a HTML tag for instance on my custom local cdn domain. The issue was not present if I used a relative path “/static/myimage.png” or localhost "
so I figured it was a DNS problem.
I was able to bypass the problem by using the --dns-prefetch-disable option of chrome.

Why not you try --dns-prefetch-disable option?

See also

Google Chrome has a built-in DNS pre-fetching mechanism which intends to improve page load performance. However, the feature has known to work to the contrary effects. With DNS prefetching enabled, users of Google Chrome may experience prolong or extended period of web browsing resolving the DNS name,

The problem is caused by unreliable implementation of DNS caching or prefetching in Google Chrome web browser, or buggy coding of Google Chrome’s network I/O (input output) stack.

By the way, have you tried your test with Firefox? It may run ok.

I have added to the dns-preftech-disable option now and will see how it behaves.

Im also running in Firefox, but I want to test in both Chrome and Firefox

1 Like

This time it happened in Firefox.

Look at the timestamp to see the timeout…
log.txt (179.0 KB)

I have no more idea.

Is this the support for a paid license? Or do I have somewhere else to go?
Currently I’m starting to look for other systems as Katalon seems to unstable for reliable use…

No, is just a user forum, with no support commitment.

Well, ask Katalon Team.

@duyluong , @ThanhTo

Entirely up to you.

Alright - thanks for the reply! I actually thought you represented Katalon.