Start browsers in private mode


This is a companion discussion topic for the original entry at https://docs.katalon.com/katalon-studio/docs/start-browsers-in-private-mode.html

Hey, I just downloaded the new version of Katalon and I am unable to make custom run.


How can I run in private mode with the new version?
If it changed I believe that also the documentation should change

I believe this is now under Desired Capabilities (last option in the list at left).

1 Like

Hi guys,

What about IE, the configuration for IE is not specified in this post.
Thanks in advance.

Hello,
IE configuration, you can do in project setting. Please find the below screenshot for more details.

What is the Desired Capability property for IE to start InPrivate mode?

Please make below changes:

Hi,

is there a way to start in private mode just for one test case? or one test suite? like an option on the script WebUI.openBrowser(’’), as we have to set at project level all tests starts in private mode.

Thank you in advance.

Hi Prabhat
Can you please post the complete property value for this. IE private mode capabilities, thanks.

Hello Pabhat,

Can you please type in here the complete names for the IE and Edge?In the above screen shot they are incomplete. Many Thanks!!

Regards,
Vik

You can use the below property value for IE private mode capabilities:

capabilities.setCapability(InternetExplorerDriver.FORCE_CREATE_PROCESS, true);
capabilities.setCapability(InternetExplorerDriver.IE_SWITCHES, “-private”);

2 Likes

Thanks @sourav.malhotra.cont I tried the same but for Edge changing to “EdgeDriver” but didn’t work. You know how to start on private that browser?

@ [rodrigocalabretta]

For edge you need to set the below capabilities

capabilities.setCapability(“ms:inPrivate”, true);

1 Like

Internet Explorer

Hi, I tried your idea and it doesn’t work for me, can you please help me?
I tried like you said and even how @prabhat.pk589 said:

and I even tried to look up on this site https://selenium.dev/selenium/docs/api/java/org/openqa/selenium/ie/InternetExplorerDriver.html
and modified the settings like this(and many other variation) and nothing works:

If you could please help me it would be very appreciated!!

@ laura.depalma2798 It should work for you now

1 Like

Thank you very much!! It worked!

I tried this setting but didnot worked for me. could you share screenshot.