Spy web : Struggling to capture the object....!

Hi,
I am using Katalon Studio Version: 5.2.0(Build: 1).
**Question 1:**While capturing object via spy web in chrome browser I followed below steps :
1.I hover the mouse cursor over the web object to be captured. Then web object is highlighted with a red border and overlay pane is also displayed with relevant xpath info.

2.But on click of <Alt + back quote> keys on the keyboard to capture object, it is not capturing the object every-time.

I need to refresh the browser couple of times/restart spy-web again to capture the object. Capture the object is becoming little difficult for me,whether I am not following steps properly or is it a general problem?**Can you please help me out…! **
Question 2: <Alt + back quote> = "Alt +` " or “Alt + ~” ?
Because in 2 different places I noticed 2 different keys.

Vinay Patel said:

Hi,
I am using Katalon Studio Version: 5.2.0(Build: 1).
**Question 1:**While capturing object via spy web in chrome browser I followed below steps :
1.I hover the mouse cursor over the web object to be captured. Then web object is highlighted with a red border and overlay pane is also displayed with relevant xpath info.

2.But on click of <Alt + back quote> keys on the keyboard to capture object, it is not capturing the object every-time.

I need to refresh the browser couple of times/restart spy-web again to capture the object. Capture the object is becoming little difficult for me,whether I am not following steps properly or is it a general problem?**Can you please help me out…! **
Question 2: <Alt + back quote> = "Alt +` " or “Alt + ~” ?
Because in 2 different places I noticed 2 different keys.

Question 1: You should HOLD Alt key and then press back quote after that.
Question 2: It should be ‘Alt + ~’ by default. You can change this settings in Preferences -> Katalon -> Object Spy

PLS have a look at this:


There you will find my view of this issue:

The KeyCode emitted by keystroke of ALT+Backquote depends on the Language and Keyboard setting of Windows OS. Spy Web’s Alt+Backstroke would work for those who use US-Layout Keyboard, but it would not work for those using NON-US-Layout Keyboard.

Vinh Nguyen said:

Vinay Patel said:

Hi,
I am using Katalon Studio Version: 5.2.0(Build: 1).
**Question 1:**While capturing object via spy web in chrome browser I followed below steps :
1.I hover the mouse cursor over the web object to be captured. Then web object is highlighted with a red border and overlay pane is also displayed with relevant xpath info.

2.But on click of <Alt + back quote> keys on the keyboard to capture object, it is not capturing the object every-time.

I need to refresh the browser couple of times/restart spy-web again to capture the object. Capture the object is becoming little difficult for me,whether I am not following steps properly or is it a general problem?**Can you please help me out…! **
Question 2: <Alt + back quote> = "Alt +` " or “Alt + ~” ?
Because in 2 different places I noticed 2 different keys.

Question 1: You should HOLD Alt key and then press back quote after that.
Question 2: It should be ‘Alt + ~’ by default. You can change this settings in Preferences -> Katalon -> Object Spy

i can’t change capture object key from object spy.

Untitled.png

4 Likes

This does not work, it is very frustrating. I am using the latest software and US keyboard. Changing this hotkey has the same effect (nothing)

Update: For me, do not run Katalon in admin mode (which means do not install in
Program Files) also the green flash is verrrry slow. Not the animation
the time to green flash. Also it does not work 100% of the time.

Hi,

Im facing same problem here tried to long press Alt then ` but nothing happens, cant capture the object. By the way, I am using now the latest version 5.0.8 is anyone here faces the same problem with the current build ? (or its just me? ) Please advice

sarah,

Please change setting of Hot key from Alt+` to Alt+a, and try capturing again.

For the reason behind, have a look at

Hi ,

I’m facing same issue for object capturing with Alt + ~. Did you get any solution for this please?

Regards.

Please specify if you have issue changing the key sequence or if you have trouble capturing objects.
About the keysequence, in Europe we do not have that key " ` " available. For some users I have asked them to change the binding to another combination like ALT J (whatever works). On my machine since I am an old timer with US keyboard, I have remapped my keybord to US.
Then, and this is where you need to be more precise: When you are on spy mode do you see a RED BOX around objects when you mouse over them? If not, for sure you won t be able to capture object and this is in any matter related to the fact that you have proper key binding.

hello, yes, you must press the keys, you must not edit the field.

hola, si, debes presionar las teclas, no debes editar el campo.

Hi,

I have the same issue, I can’t capture objects using " Alt + ’ " . I tried to modify the Hotkeys settings from the Katalon studio preferences but it is a non editable field.
PS: For some objects, I see a RED box around when I mouse over them. For other objects, I only see a red line below and when I right click on the element, I do not see the option “Capture object”. There is a solution? Or they are not identifiable elements?

You are not supposed to “edit it”.

You just locate the mouse cursor in the field labeled “Capture object”, press ALT key and strike any Key (e.g, ‘a’). Then the value in the field will be replaced to the new key sequence.

1 Like