Somethings wrong with 3+1 storeEval or even storing 3 to a variable

Hi,
This have give me a lot of headache already.
Im using storeEval|${n}+1|n

everytime it reaches 3+1

[info] Expand variable ‘${row}+1’ into ‘3+1’

[error] Threw an exception: Unexpected identifier

but if I input skip 3 everything is alright.

The problem is very difficult to procrastinate because some of my test cases are working but whenever I start creating new again I fear it will receive that error again.

I tried IFs condition to bypass such as :
if row==2
store|3|row
if row==3
store|4|row

still got error…

tried also gotoIf and gotoLabel and still the same error. Really appreciate if someone hear this. Thanks!

I noticed if I add another store before (which is not related to the variable) storeEval accumulator error will appear.

image.png

1 Like

Thank you for the feedback. We will release version 3.4.11 this week to address this issue.

We’ve released 3.4.11. Could you please check again and tell us the result? Thank you for your feedback.

Hi Alex,

Yes. Its fixed! Good job