Slow stepping in debug mode

Hi everyone, I have a knit-picky issue that I have run into. When stepping through a test in debug mode, it moves extremely slowly between steps. However, when straight running the test, it executes in a perfectly acceptable amount of time. In general, if I set the breakpoint at the beginning of a test and step through each line, it can take up to 3-4 minutes to step through 175-200 lines, whereas just running the test takes 5-10 seconds.

A quick example:‘BreadCrumbs/serviceCampaignActionsBreadCrumb’))

js = ''

js = 'return document.querySelectorAll(\'#CampaignActions_DBMSEPAGE_rgManifest_ctl00 tr a\')[1]'

customerDetailsLink = WebUI.executeJavaScript(js, null)

The breakpoint being set on the… line. I press F6, and in the console, it displays the next line (js = ‘’) almost immediately. After a couple seconds, the arrow indicator in the text editor finally moves to the next line. When pressing F6 again, to execute the js = ‘’ line, it displays the next line in the console almost immediately, but takes 3-4 seconds on average for the arrow indicator to move to the next line (js = 'return document…). It seems that just setting the js variable back to blank should be pretty quick.

I read somewhere online that there may be some logging that is going on in the background, but I do not know how to find the setting to lower the logging level, or if that would even be the issue.

Any guidance on speeding up stepping through the test case would be greatly appreciated!!!

Happy Coding

Looks like someone else is having same/similar issue and has reported as a bug:
Katalon 7.9.1 is slow on debugger - Katalon Studio / Bug Reports - Katalon Community

Hi @devin.brown, @AndyG72

This is a performance issue when we upgrading the Eclipse framework from v4.6 to v4.16 since the feature: Value displayed for method exit and exception breakpoints released.

The workaround is to uncheck Enable for local launch types option in Windows/Preferences/Java/Debug


@duyluong Thank you very much! This makes debugging much quicker.

1 Like

@duyluong just noticed that turning that option off appears to stop Edge Chromium browsers from opening when running automated tests.