Set Text is not working for particular text box


We have one text box field on web page called Duration (months)*. I am trying to enter a text in respective field using Set Text action but, it is not entering the value in it. It is showing an error “Unable to find object”. I have used the below xpath.
//input[@id=‘c_Duration’] and it is highlighting properly with an unique field on page.
Manually I am able to enter the value and it is taking the input text. For the details, please see the attached screenshot. I have tried different methods to identify the object but, still it is not working.
The application is built in SharePoint 2013 with BPC.


please check if it’s NOT part of some iFrame

Hi Andrej,

Thank you for reply but, I have checked and there is no iFrame. Please let me know if you need more information.

can i ask you for test change xpath and sent text or send keys:

//input[@id='c_Duration']/preceding-sibling::inputsince input with id have display: none; style set

I have tried above xpath and executed the script. Still, it is not accepting the value. Please see attached screenshot of execution steps.



that’s strange, because @id=‘c_Duration’ is set as invisible… input box before is actually one you want fill

:frowning: Is there any workaround?