Set single quotes in text field

Hi, I’ve got some little problem over here
I’ve got some text field and I need to put text like ‘Text’ in it (with single quotes on start and end)

I’ve tried
WebUI.setText(findTestObject(‘Test_object’), ‘‘Text’’)
WebUI.setText(findTestObject(‘Test_object’), “‘Text’”)
WebUI.setText(findTestObject(‘Test_object’), ‘‘Text’’)
but none of them is working as I want (they all put Text in field, without single quotes)
Can anyone help me please?

How about this?

WebUI.setText(findTestObject('Test_object'), "\'Text\'")

You need to escape a single quote char ’ with a preceding back-slash \

thanks, but it doesn’t help
I’ve tried both (setText and SendKeys) but none of them are working

It seems that your testObject don’t accept the single quote char. Because if you try on the Google page, your second solution works

well… there was a problem with my keyboard layout setting :slight_smile: USA-Internation layout support single quota very poorly and “lock” first single quote until it pressed twice :roll_eyes: