SendKey Key_Enter after Type results in double quotes

FF 57.0.4 64 bit, Windows 7

When I play these commands, it adds a double quote to the end of the value:

selenium.sendKeys(“id=search_text”, “apple”)

selenium.sendKeys(“id=search_text”, “${KEY_ENTER}”)

also tried:

selenium.type(“id=search_text”, “apple”)

selenium.sendKeys(“id=search_text”, “${KEY_ENTER}”)

In the entry box, I need it to display: apple
Results are: apple""

How do I get rid of the double quotes? The strange thing is if I execute the commands manually one by one, it seems to be working fine. It does not add the double quotes. The double quotes are specifically introduced by the Key_Enter command.

Hi Peter Lor,

Are you talking about executing those commands in Katalon Studio?


Hi Vinh,

No, for the recorder. What I pasted was the raw data. In the recorder I have:

sendKeys, id=search_text, apple (command, target, value)

Manually executing that step results in what I expect which is the word “apple” in the text box. Playing the test suite results in: apple"". It adds a random double quote to the end of the word. I also tried escaping the box with a TAB button and it does the same thing.

Hi. We’ve fixed this in 3.4.7. Please use CSS locator, e.g. sendKeys | css=#search_text | ${KEY_ENTER}. Currently, only Chrome is supported.