Remote Desired Capabilities


This is a companion discussion topic for the original entry at https://docs.katalon.com/katalon-studio/docs/remote-desired-capabilities.html
1 Like

I have trouble setting “useAutomationExtension” to false. I’ve tried a lot way, but without success.

2019-07-02_10h20_04

1 Like

This does not describe how you can set things up for GRID very well, so I thought I would post some tips.

Parallel Execution using more than one Browser. Firefox and Chrome example:

Go to Project > Settings > Desired Capabilities > Custom
Click Add
Enter a Name (Ex. remotefirefox)
Click on the cell row under the Value column
You should now see a button appear with three dots… Click on that

The Custom Execution Configuration Builder should appear
Click Add
Under Driver Name you see that Android is selected by default, click on that cell
In the drop down menu, select Remote
You should now see that the Preferences cell updated to display some pre-populated data, click this Cell
Click the button with the three dots

Driver Builder screen should appear
Here you can enter the URL for your grid hub (Ex. http://localhost/wd/hub)
Then click Add
Name: browserName
Type: String
Value: firefox
(Click Add again to enter any other desired capabilities)
Click OK to close this window
You should now see that the Preferences have been updated

You can now click Add and repeat the steps for Chrome

Once done you should see something like this:
gridkatalon

Click OK and go to your Suite Collection screen, and you can select them under “Run with” and the two different browsers with now execute in parallel in GRID.

1 Like

Hi,

Did you manage to set seAutomationExtension” to false in chrome ?

to disable this pop up
image

1 Like

I personally have not seen that pop up. My tips were more for setting Katalon up to use Selenium Grid.

1 Like

here is the solution :
image

1 Like

@ouassa.h

Please share the detailed Steps to use the above screenshot. After adding this goog:chromeOptions property I am facing same issue.
Thanks in Advance.

1 Like

Hello @ naveenkumar.sampath, are you trying to run locally or remotely?

@ouassa.h
I have tried in remotely

naveenkumar.sampath Please follow these steps :
Go to Project ==> Settings ==> Desired Capabilities ==> Custom ==>Add new Custom Name
Drive name : Remote
ill in the following values :
Remote server URL : Your Selenium grid server
Remote server type : Selenium


Set the property useAutomationExtension to false in goog:chromeOptions value

Please let me know if it’s working

I have added the property called goog:chromeOptions and have shared my screen. but still I am Pop-up Message. Please guide me if anything I need to add.

@naveenkumar.sampath you use selenium grid ?
Your hub is it up ?

No I am not using selenium grid.I have just configured using the below Steps:

  1. Project ==>Settings ==> Desired Capabilities ==>WebUI==> Chrome==>Add new
    browserName : Chrome
    goog:chromeOptions -->Dictionary --> arg as list & useAutomationExtension–>False

Ok so in local not in remote

Yes @ouassa.h

You must put args instead of arg
As explained above

After updating to args in property, we are facing same issue

Plz, remove browserName since you are alredy in chrome

We also tried deleting the browerName and rerun the job, facing same issue. Still I am getting that pop-up

Plz, share screnshot pop-up and error log