Reload plugins is not working in katalon V6.2.0


Still same problem with V6.3.0.rc7

Here is the detailled log file :

Error reloading plugins
com.kms.katalon.plugin.models.ReloadPluginsException: Unexpected error occurs during executing reload plugins under account: credential:, endpoint:
at com.kms.katalon.plugin.service.PluginService.reloadPlugins(
at com.kms.katalon.composer.handlers.ReloadPluginsHandler$
Caused by: com.kms.katalon.plugin.models.KStoreClientExceptionWithInfo: Unexpected error occurs during executing get latest plugins
at com.kms.katalon.plugin.service.KStoreRestClient.getLatestPlugins(
at com.kms.katalon.plugin.service.PluginService.fetchLatestPlugins(
at com.kms.katalon.plugin.service.PluginService.reloadPlugins(
… 2 more
Caused by: org.apache.http.conn.HttpHostConnectException: Connect to [,] failed: Connection refused: connect
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(
at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(
at org.apache.http.impl.execchain.MainClientExec.establishRoute(
at org.apache.http.impl.execchain.MainClientExec.execute(
at org.apache.http.impl.execchain.ProtocolExec.execute(
at org.apache.http.impl.execchain.RetryExec.execute(
at org.apache.http.impl.execchain.RedirectExec.execute(
at org.apache.http.impl.client.InternalHttpClient.doExecute(
at org.apache.http.impl.client.CloseableHttpClient.execute(
at org.apache.http.impl.client.CloseableHttpClient.execute(
at com.kms.katalon.plugin.service.KStoreRestClient.executeGetRequest(
at com.kms.katalon.plugin.service.KStoreRestClient.getLatestPlugins(
… 4 more
Caused by: Connection refused: connect
at org.apache.http.conn.ssl.SSLConnectionSocketFactory.connectSocket(
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(
… 15 more

1 Like

Hi again,

Solved with manual proxy configuration from my side (proxy configuration from my company).

Hope, it could be same issue for others.

Best regards

Hello @huynguyen,
How I can reload the Katalon Studio version? Sorry, I’m a newbie in using Katalon Studio. I just installed the latest version.

Hello @Arnico,

So after you reload 6.3.0.rc7, you setup the manual proxy config?
Can you show me a sample setup?

Thanks in advance for the assistance.


Yes, proxy configuration was my problem.
FYI, someone gave me proxy infos (ex :
Then in Preferences/Katalon/Proxy

  • Proxy Option : Manual proxy configuration
  • Address : xxxx-proxy.yyyyyyyy
  • Port : 9999
1 Like

Hello @Arnico,

Thanks for the information. Can you assist me on how to reload the Katalon Studio version 6.3.0.rc7?

Thanks again.

You can find v6.3.0.rc7 in this link:

Hello @Alice and @huynguyen,

I tried using the v6.3.0.rc7 but there is still an error (the same error)
The main issue on our end is not specific to “Reload Plugins” but the “Basic Report” Plugin, as we cannot use it on our end. It is not available in the Project Plugins even though the Basic Plugin is Active on my online account.

With that said, do you have a downloadable version of the Basic Report Plugin, because I’m thinking on manually installing it in Katalon, if possible.

Thanks in advance for your response.

@huynguyen any updates on Geecarl’s issue?

Hi @geecarl.c.abalajon,
Are you behind a proxy? If yes, have you configured the proxy settings in Katalon Studio?

@huynguyen I work together with @geecarl.c.abalajon. Yes, we manually set the proxy settings and afterwards got this different error regarding invalid certification path,

I used the latest version Katalon Studio 6.3.1

Hi @jan.michael.w.cerna,
Please refer to this post and check if it works. Plugin Store behind firewall

1 Like

I was having the same problem using Ubuntu and Katalon 6.2.2, behind a proxy.
I downloaded Katalon 6.3.1 and problem still occured.
Switched proxy option to manual configuration (under Window -> Katalon Studio Preferences -> Katalon -> Proxy) instead of “Use system proxy configuration” and it started working.

Hi, same problem, Im suspecting its the same problem that Arnico has (company proxy ixsue). Ill check it and Ill get back to you

Thank you, I’m still working with our Tech Team on this. I will keep you posted.

I fixed it. Was a company proxy problem.

While configuring the proxy seems to be the solution, you will sooner or later bump into the issue where the proxy will route your requests to the wrong side of the internet pound. I have to choose now; Either I can reload plugins OR I can run my tests because my application is on the intranet. So much for that design!

When i set the proxy in Katalon to use manual proxy, then i am able to reload plugin, but whenever i change the proxy setting to use System proxy configuration, i am not able to reload plugin. Got error. Can someone help tell me how to fix this?

I assumed the system proxy configuration is the same as browser proxy setting, is it? Where to check the system configuration?

You should use “Manual proxy configuration”.

“Use system configuration” seems to be unreliable.

If you choose “Manual proxy configuration” which lacks “proxy-bypass-list” feature, then your test case scripts will become unable to reach to the host on your interanet such as or

But there is a work around. See: