Proxy Preferences


#1

This is a companion discussion topic for the original entry at https://docs.katalon.com/katalon-studio/docs/proxy-preferences.html

#2

The path to this configuration section is really Preferences > Katalon > Proxy


#3

@Enrique_Castilla Thank you for your feed back. The document will be updated soon.


#4

Change Proxy is useful to Function-RUN, but it does not take effect for Function(Record Web).
My Ubuntu OS: Ubuntu 16.04


#5

I’m using Katalon Studio versions 6.1.5 and 6.2.1 on Windows 7 and found the same problem in both versions.
If the proxy is configured as “Use system proxy configuration” whenever I lunch a test case (or suite) it takes several long minutes before the test starts. After this delay everything works ok, I mean Katalon Studio seems to be using the system proxy configuration and has no problem to reach URLs through the proxy.

To solve it I just configure the proxy at Window->Katalon Studio Preferences->Katalon->Proxy as “Manual Proxy configuration” and the delay disappears.

However, if I configure the proxy as “Manual Proxy configuration” from the product activation dialog, this workaround doesn’t work
The delay happens even when there is no need to use the proxy because all the URLs are from the Intranet.


#6

It would be really essential that we could have an additional field called “proxy host exception”

I have a dilemn :
When I configure proxy, katalon analytics and plugin are working great, but test cases on internal network are failing.
And when I inactivate proxy configuration, analytics and plugins are unreachable, but my internal network test case is a success …

if I could add my internal adresses in an exception list, I would have no more problem.

You may add an input as in Jenkins configuration for example (field “no proxy host”):

for information, a bug has already been open for that :


#7

I reported an issue on Github, as this important features seems to affect a lot of people in companies,
where intranet applications are tested, but internet access is only possible via proxy.

Please see here:


#8

We are seeing the proxy option - “Use system proxy configuration” is not working and it behaves as like option “No proxy”. We assume that this option should take proxy details updated in LAN Settings but it is not happening.

Please suggest us why it is not working and help us resolving this. It is blocking automation of our total project critically.

Proxy configuration in Lan Settings (Assuming it as System proxy configuration)
image

Proxy Configuration screen in Katalon which is not taking system proxy configuration -
image


#9

Hi @ysubramaniam

The option Use system proxy configuration means Katalon Studio tries to guess which proxy server your system is behind and to sync with these settings. Hence, in some cases, it may be not working. Please try manually setting up the proxy server and see if it works.

Regards,
Jass


Proxy not used while recording, only when re-running test cases
#10

@Jass In that case, there is no way to provide exception list within Katalon. If my test case has to run a scnenario in combination of Intranet and Internet, we may not able to run it in both cases as Intranet sites requires to be in exception list which is not available in Katalon Manual proxy configuration. Another scenario, if we are running with “No proxy or Use system proxy”, we may not able to able load result (Basic report) plugin especially in console mode.

Bug has been raised for the same and many for these issue. Kindly assist on this asap. Thanks!

Bug link - Basic Report plugin - Proxy Setup Issue


#11

Hello @ysubramaniam

I’m glad to let you know we’re about to release an offline version of Katalon Studio. You can use Katalon Studio and all plugins without the Internet. Hence, I think your issue will be resolved with the offline Katalon Studio.

Jass


#12

@Jass Thanks for the update. This may resolve our Basic plugin issue but still to integrate with Katalon Analytics and to run a combination of test cases w and w/ internet, we may need proxy issue to be resolved. So it will be helpful if we get a fix for it. Thanks once again.


#13

Hola @ysubramaniam,

In the offline Katalon Studio, you can also integrate with Katalon Analytics. But for running a combination of test cases with and without the Internet, we will consider to put it in our product backlog.

Regards,

Jass


#14

Hello Jass,

Thanks for consideration.

Can you please update us on ETA and release details of offline version of Katalon Studio and its plugins?

Regards,
Yuvaraj S


#15

I have an idea for work around. See the following post.


#16

Thank you very much @kazurayam for this tip !
I struggled a little bit with these options :hot_face:, but now it is working fine and I can use plugins & analytics :star_struck:

For those who want to do the same, here is an example of my config :
These “- -” parameters have to be sent to chrome within “args” parameter like this :
image

As --proxy-bypass-list did not work for me, I finally used --proxy-pac-url and --proxy-auto-detect.
complete list with chromium capabilities can be found here :
https://peter.sh/experiments/chromium-command-line-switches/


#17

So did I.

Options or switches to configure browsers — too messy, too difficult to find out what is right.


#18

Hey there!

So I’m using manual proxy configuration for my project.
The problem is that every time I start the project it request the Activation (so I need to remove my proxy options - activate - and then turn the proxy again) which is quite bothering.
Also if I have my project open and I’m developing a test case - Katalon says it’s not able to activate (even though it was activated when I started the program) and it turns off in 5 minutes.

Is there anyway hot to bypass this - it’s really bothering?


#19

Hello Marek

May I know which version of Katalon Studio you are using?

Jass


#20

I’m using version 7.0.3 - running on macOS Catalina