Problems during content assist. I am using Katalon studio version 8.6.6 on Windows 10. I am always getting this 'Groovy code completions'proposal computer from 'org.codehaus.groovy.eclipse.codeassist' plugin related issue

*Had searched in the forum for similar topics but no resolution has helped in resolving this issue.

  • Problems during Content assist
  • NO Content assist were displayed .




I will investigate more and back to you soon

@Navya_pnd Please help to share the error log file


We need to know more detail so that we can reproduce your findings on our PC.

Could you show us the full source code of your Test Case?

Could you tell us at which line# what character you typed in the editor when you got the error?

Could you show us the error log file which would contain an StackTrace of the Exception?

How to get the log? See the following:

Please, when you make a new post, use the “Code Formatting” syntax to present your code, logs etc for better readability.

I have been not getting any code assist/code suggestions at all.
Even the error is observed at the very first line itself on trying to open browser(WebUI.), on giving (.) and waiting the error is seen.
The environment variable HOME is not set.

Could you show us the error log file which would contain an StackTrace of the Exception?

How to get the log? See the following:


I have a doubt that your Katalon Studio installation might be somewhat broken (some jar files are missing).

How many days have you worked on Katalon Studio after you installed it without the “Problems During Content Assist”?

Do you have any idea since when the problem started to occur? Do you have any idea what triggers it?

Why not you install Katalon Studio again, and see how it goes?

Attaching the error log


.log (478.0 KB)

1 Like

dear @Navya_pnd : please try the below (got this from stackoverflow)

You can either wait until the indexer is done or increase the timeout by setting the ‘org.eclipse.jdt.ui.codeAssistTimeout’ Java environment variable when starting Eclipse, e.g.

 -vmargs -Dorg.eclipse.jdt.ui.codeAssistTimeout=60000

Is it this stackoverflow thread?

Please tell us into which file for Katalon Studio @Navya_pnd should write this line?

yes, it is from stackoverflow @kazurayam

please add this in Run Configuration , then select arguments tab and in the VM arguments field add the below command and click on the run button with this modified argument

-vmargs -Dorg.eclipse.jdt.ui.codeAssistTimeout=60000

restart katalon studio for the changes to take effect

Let me know if it works

I have never seen “Run Configuration” widget in Katalon Studio. It looks to be a feature for developers’ only.

Please guide us how to reach to it?


Thank you all for great discussion. When I check on it, this is a known bug which will be fixed in v10.0.0, Q1 2024. In the meanwhile, I would like to suggest you to:
Go to Katalon -> Settings -> Java -> Editor -> Content Assist. Under Auto Activation, by default the Auto Activation delay (ms) is 500. You can try to increase or decrease it to see if it works on this case . Thank you!

i have given the navigation on my above reply , right click and then follow the above navigation. screenshot is attached in my previous reply

Hi Monty_Bagati

Thankyou for your reply.
But I am unable to navigate to open Run Configurations.Can you please help me with the navigation on how to reach Run Configuration.

go to your script → right click–> Run As → Run Configuration

Under VM Arguments , paste the command

And this works.

Thanks everyone for your inputs.
Thankyou @Monty_Bagati

1 Like

I am glad I was able to help :slight_smile:

I am seeing the Code assist issue again in each new session.
Each time, I start a session I need to input the VM Arguments command.
I can not understand why this is happening .

And “Run” is not being enabled on adding the argument command, I am clicking on “Apply” button