Problem with Check function

Dear all,
I have problem with check function: WebUI.check(findTestObject(‘Registration/cbox’))
xpath = //input[@id=“OfficialRule”]

After run, the script stopped at check function and I got the error as below:

check(findTestObject(“Registration/cbox”)) FAILED.


com.kms.katalon.core.exception.StepFailedException: Unable to check object ‘Object Repository/Registration/cbox’ (Root cause: org.openqa.selenium.WebDriverException: unknown error: Element <input type=“checkbox” name=“OfficialRule” id=“OfficialRule”> is not clickable at point (58, 547)

Html of the object: <input type=“checkbox” name=“OfficialRule” id=“OfficialRule” aria-required=“true” aria-invalid=“true” aria-describedby=“OfficialRule-error” class=“valid” style="" xpath=“1”>


Try adding WebUI.waitForElementVisible(findTestObject(“Registration/cbox”),5) or WebUI.waitForElementClickable(findTestObject(“Registration/cbox”),5) before the check.

Hi Mate,
I tried and still got the same error.
Please advise. Thanks

Can you try instead of check() and see what happens?

I ran into a similar problem where the input element was overlapped by a label element right underneath.

Looked like:
div> (wrapper)
… input> (radio/checkbox)
… label> (received the click instead of the input element)
Can you give the full error message ?

My current workaround is to use the ckeck keyword on the label element

I also tried with and still error.

12-07-2018 10:09:46 PM click(findTestObject(“Registration/cbox”))

Elapsed time: 0.435s

click(findTestObject(“Registration/cbox”)) FAILED.
com.kms.katalon.core.exception.StepFailedException: Unable to click on object ‘Object Repository/Registration/cbox’ (Root cause: org.openqa.selenium.WebDriverException: unknown error: Element is not clickable at point (58, 779). Other element would receive the click:

(Session info: chrome=70.0.3538.110)
(Driver info: chromedriver=2.43.600210 (68dcf5eebde37173d4027fa8635e332711d2874a),platform=Windows NT 10.0.17134 x86_64) (WARNING: The server did not provide any stacktrace information)
Command duration or timeout: 0 milliseconds
Build info: version: ‘3.7.1’, revision: ‘8a0099a’, time: ‘2017-11-06T21:07:36.161Z’
System info: host: ‘TRUNGHA’, ip: ‘’, ‘Windows 10’, os.arch: ‘amd64’, os.version: ‘10.0’, java.version: ‘1.8.0_181’
Driver info: com.kms.katalon.selenium.driver.CChromeDriver
Capabilities {acceptInsecureCerts: false, acceptSslCerts: false, applicationCacheEnabled: false, browserConnectionEnabled: false, browserName: chrome, chrome: {chromedriverVersion: 2.43.600210 (68dcf5eebde371…, userDataDir: C:\Users\LENOVO\AppData\Loc…}, cssSelectorsEnabled: true, databaseEnabled: false, goog:chromeOptions: {debuggerAddress: localhost:49890}, handlesAlerts: true, hasTouchScreen: false, javascriptEnabled: true, locationContextEnabled: true, mobileEmulationEnabled: false, nativeEvents: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: XP, platformName: XP, rotatable: false, setWindowRect: true, takesHeapSnapshot: true, takesScreenshot: true, unexpectedAlertBehaviour: , unhandledPromptBehavior: , version: 70.0.3538.110, webStorageEnabled: true}
Session ID: 98cd1525cdae3ac15efa4d9a563946d6)
at com.kms.katalon.core.keyword.internal.KeywordMain.stepFailed(KeywordMain.groovy:36)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.stepFailed(WebUIKeywordMain.groovy:65)
at com.kms.katalon.core.webui.keyword.internal.WebUIKeywordMain.runKeyword(WebUIKeywordMain.groovy:27)
at com.kms.katalon.core.webui.keyword.builtin.ClickKeyword.execute(ClickKeyword.groovy:67)
at com.kms.katalon.core.keyword.internal.KeywordExecutor.executeKeywordForPlatform(KeywordExecutor.groovy:53)
at com.kms.katalon.core.webui.keyword.WebUiBuiltInKeywords$click$ Source)
at User registers successfully with valid registers successfully with valid inputs:48)
at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(
at com.kms.katalon.core.main.TestCaseExecutor.runScript(
at com.kms.katalon.core.main.TestCaseExecutor.doExecute(
at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(
at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(
at com.kms.katalon.core.main.TestCaseExecutor.execute(
at com.kms.katalon.core.main.TestCaseMain.runTestCase(
at com.kms.katalon.core.main.TestCaseMain.runTestCase(
at com.kms.katalon.core.main.TestCaseMain$runTestCase$ Source)


try to change your Project --> Settings --> Test Design --> Web Locators as Xpath and spy the object again. After that change new object path to your view or script

1 Like

Hi Timo,
It does not work. Here are my settings.

The “element not clickable at point” (other element would receive the click) error usually occurs when there’s some other web element obscuring the one you are trying to click.
Usually, this means waiting for the element to go away, that’s why I suggested using different “wait” commands before trying to click or check the element.

If this doesn’t help, the next thing would be to use javascript, as described here: Unable to click on Object, Other Element Would receive click.


in this screenshot you are using attributes instead of xpath, spy your object again as I said in my previous comment.
there should be results like

hi Timo,
I changed and it worked.
Thanks a lot.