Problem starting Test in Katalon studio

Hi,

I am on the lecture “Customizing the Execution Log in Katalon Studio”, using Sample Web UI Test Project (Shopping Cart).
My Test cases are not running, but it’s saying execution ‘done’.

Console log:
Error occurred during initialization of VM
java.lang.Error: java.lang.ClassNotFoundException: groovy.lang.GroovyClassLoader
at java.lang.ClassLoader.initSystemClassLoader(ClassLoader.java:1463)
at java.lang.ClassLoader.getSystemClassLoader(ClassLoader.java:1430)
Caused by: java.lang.ClassNotFoundException: groovy.lang.GroovyClassLoader
at java.net.URLClassLoader.findClass(URLClassLoader.java:387)
at java.lang.ClassLoader.loadClass(ClassLoader.java:419)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:352)
at java.lang.ClassLoader.loadClass(ClassLoader.java:352)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:348)
at java.lang.SystemClassLoaderAction.run(ClassLoader.java:2218)
at java.lang.SystemClassLoaderAction.run(ClassLoader.java:2204)
at java.security.AccessController.doPrivileged(Native Method)
at java.lang.ClassLoader.initSystemClassLoader(ClassLoader.java:1450)
at java.lang.ClassLoader.getSystemClassLoader(ClassLoader.java:1430)

1 Like

Hi,

This problem has been known. Although our developers are working on it, you can solve this problem by creating another new project.

3 Likes

Any progress on this? I’ve created a new project which worked until I made an edit to my test script - then I got the same error again. Creating a new project after every edit isn’t going to work for me…

Any advice greatly appreciated!

I’m running KSE 8.6.5 and getting this issue. It works so far if I close the project and then reopen it. Then I can execute the test suite. I didn’t get the issue on 8.4.1 but have done since the upgrade to 8.6.5

1 Like

Updating this post as for me this still regularly happens on 8.6.6. A bit frustrating to be honest.
It’s typically always the first (local) run I try that results in this. Never saw this happening on the pipeline. Even cleaning the garbage does not solve/prevent it.
image

Close project and open it again and same test case first run and it works.

Error:
Error occurred during initialization of VM
java.lang.Error: java.lang.ClassNotFoundException: groovy.lang.GroovyClassLoader

It is Feb 2024 and I am having this issue. I created a free account a month ago and only got around to actually working with the program today. Additionally my trial expires tomorrow, so I’m not really holding out hope that this software will work for me.

I cannot run a single test without running into this error. A test as simple as opening the browser and going to a specific url results in this error.

I have done the following:

  1. Created a new project
  2. Created a new org with a new project
  3. Updated to the latest version of Katalon studio
  4. Uninstalled Katalon and reinstalled it (9.3.0, build 212 on Windows 11)

None of this matters. I get the same error on everything I attempt to do. Coworkers are able to use the program to evaluate with no issues, but I am unable to use it to perform my evaluation. What additional steps do I need to take? What environmental issues might I have on my computer that my coworkers do not have, or what might I be missing that they have?

Error occurred during initialization of VM
java.lang.Error: groovy.lang.GroovyClassLoader
at java.lang.ClassLoader.initSystemClassLoader(java.base@17.0.7/ClassLoader.java:1995)
at java.lang.System.initPhase3(java.base@17.0.7/System.java:2246)
Caused by: java.lang.ClassNotFoundException: groovy.lang.GroovyClassLoader
at jdk.internal.loader.BuiltinClassLoader.loadClass(java.base@17.0.7/BuiltinClassLoader.java:641)
at jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(java.base@17.0.7/ClassLoaders.java:188)
at java.lang.ClassLoader.loadClass(java.base@17.0.7/ClassLoader.java:520)
at java.lang.Class.forName0(java.base@17.0.7/Native Method)
at java.lang.Class.forName(java.base@17.0.7/Class.java:467)
at java.lang.ClassLoader.initSystemClassLoader(java.base@17.0.7/ClassLoader.java:1981)
at java.lang.System.initPhase3(java.base@17.0.7/System.java:2246)

1 Like

Hi,

Sorry to hear that. I will ask my team and back to you with the update. As it is our new year coming, I am not sure that we can get this answer in few days but I will try.