Null Pointer exception in JDTUtil.findMethod

I just upgraded to 7.7.2 (from 7.0.2). I find that once I run a test case, all of my open objects need saving again. After running the test case, I see this in the error log file.

at com.kms.katalon.util.jdt.JDTUtil.findMethod(
at com.kms.katalon.custom.parser.CustomKeywordParser.findJavadoc(
at com.kms.katalon.custom.parser.CustomKeywordParser.collectMethodJavadocs(
at com.kms.katalon.custom.parser.CustomKeywordParser.parseCustomKeywordFile(
at com.kms.katalon.controller.KeywordController.parseCustomKeywordFile(
at com.kms.katalon.composer.keyword.handlers.EditorSavedHandler.lambda$0(
at java.util.concurrent.Executors$
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$

Launcher status after execution process completed: Running

Hi @vjohnson,

If you are using Katalon Studio IDE, this is a warning message in error log file and doesn’t harm your test.
If you are using Katalon Runtime Engine, you should download v7.7.8.rc2, this version will hide these messages in the execution log and will apply for 7.8.0 official release in next week.


1 Like

Hi @vjohnson,
The fact that your test cases need saving again on test execution has nothing to do with the log you posted. As @duyluong has said, this is just a warning message that comes from another reason and it doesn’t harm your test. However, you will do me a really big favor if you can share your project (via private messages) for investigation, so that we can fix what causes that message for good.
By the way, we will try on our side to reproduce the issue that cause the objects to become unsaved. You can help by sharing with us the type of the opened objects.

Thank you for your time.

It is a Restful web service request.

Here is an example of what is happening…
I have 5 open objects – post, get, patch, put and delete.
All have been saved, but once I run them, an asterisk shows in front of the name to save again.
I saved just one of them and executed it.
If I then click save all, the one that I ran now has an asterisk to be saved again but the others do not.
If I click save all again, the one that I ran no longer has the asterisk, but all others do.

I upgraded to v7.8 and I no longer have an issue with Save/Save All.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.