[New Release] Katalon Studio 8.5.0 - September 21, 2022

Hi Community members! :wave:

Today we’re releasing a new version of Katalon Studio with new changes, features and improvements below.

What is new

From version 8.5.0 onwards, Katalon Studio has two editions: Katalon Studio - Standalone Edition and Katalon Studio - Platform Edition.

The Katalon Studio - Platform Edition is a component of the Katalon Platform - a modern, comprehensive quality management platform that enables teams to efficiently test, launch, and optimize testing without any complicated setup. With the platform solution, test automation teams can collaborate, manage, scale, and continuously improve testing operations. See About Katalon Platform.

Katalon Studio - Platform Edition and Standalone Edition share most of their features. When they do, the documentation only mentions “Katalon Studio”. When they do not, the documentation will specify which Edition that feature is available for: either “Katalon Studio - Standalone Edition”, or “Katalon Studio - Platform Edition”.

New features

  • [Dynamic Test Suite] In the Query Provider of the dynamic test suite, added the Built-in Search option. See Dynamic Test Suite.

Enhancements

  • Added Chrome 105 compatibility.
  • Added Edge 105 compatibility.

Changes for Katalon Studio - Platform Edition

  • Introduced a new dialog to open a project and removed the option to create a new project in Katalon Studio. Katalon TestOps and Git integration are required to open a project in Katalon Studio. See Open a project in Katalon Studio - Platform Edition.
  • In Project Settings > Project Information, added the information of TestOps Server URL, Repository URL, and Project Type. You can now change your project type to test different types of applications in the same project. See View and edit your project information in Katalon Studio - Platform Edition.
  • In Project Settings, removed the TestOps screen. Katalon TestOps is now enabled by default for every user, except for On Premise license and offline activation.
  • On the main toolbar, clicking on the TestOps icon navigates you to the Project Settings > Project Information screen.
  • In the Generate Command for Console Mode dialog, removed the option to override TestOps project ID. See Command Builder in Katalon Studio.
  • [Git integration]:
  • [Debug mode]:
    • Running in debug mode does not automatically export basic reports (HTML, PDF, CSV).
    • Removed the ability to export reports manually.
    • Running in debug mode does not automatically send execution results to Katalon TestOps.

Known limitations

When working with Git on Katalon Studio Platform Edition running on Virtual Machine with Linux, you might encounter this error message: “Failed to write credentials for to secure store. No secure storage modules found.”

Workaround: Katalon team is going to fix this issue in upcoming releases. For the time being, there are two solutions to this limitation:

On your Linux machine, open Git on a browser. Copy and paste your script changes into your file in Git on the browser, then commit changes.

Or:

Copy your current project on your Linux or Windows machine, then use independent Git to commit changes.

Documentation


Happy testing!
Katalon Community team

2 Likes

where can I download the standalone edition? In the website seems the only one available for download is the platform edition.

1 Like

You can grab it from git:

I think the standalone edition is the one without PE in the name.

1 Like

Thank you for the question @blair.inmenzo, you could log in here https://testops.katalon.io/ and download Katalon Studio with these 2 easy steps:

Step 1: Click the download icon (next to the view demo site)


Step 2: Choose the right version for your machine

Hope this helps.

Katalon Studio release 8.5.0 is out:

Release notes will appear here when they’re published:

1 Like

@Russ_Thomas We moved the version history to the new one. The link is here: Version 8.x | Katalon Docs

2 Likes

Having done a clean install of version 8.5.0, after logging in to Katalon Studio, we’re faced with a modal window (titled ‘Open Project’) that appears to be forcing us to select a Project, but upon clicking ‘Fetch Projects’, no projects are found (despite the user in question being part of an organisation that has active projects configured).

We’re therefore unable to open any projects and as a result cannot continue with our work.

I notice from the post above that it states that GIT integration is now required to open a project in Katalon Studio - could this be related?

We tested GIT integration with a previous version of Katalon Studio and found native GIT integration to be insufficient for our needs, and flaky, so we have been using a third party GIT integration solution; but are Katalon now saying that native GIT integration is now mandatory in order to even open a project?

I’m hoping I’ve misunderstood and would be grateful for some urgent clarity on this matter, as we are now effectively blocked from working (I’ve also created a support ticket).

2 Likes

Thank you for sharing this with us. Given you are our paid user, I would confirm that our Customer Support team has received your ticket and they are on it. Once the answer has been provided, I will share on this forum for a larger audience’s benefit. Thanks for using Katalon.

Hi @kevin.mcandrew1,

One of our support team members has already reached out to you. I’ll also post his response here should anyone else run into similar problems as yours.

The Katalon 8.5.0 package you installed is the Katalon Studio Platform Edition which is required to create a project with Git integration on Katalon TestOps. Please refer to Open a test project in Katalon Studio - Platform Edition and also View and edit your project information in Katalon Studio.

If you don’t know how to link your GitHub repository to your TestOps, we also have an article on How to link Github Repository to TestOps? You can view the video for more detail.

Hope this helps, please don’t hesitate to reach out to us via this thread or our support team if you have any other concerns. :smile:

@vu.le Thank you, but unfortunately the link I was sent to download the Standalone edition appears to download the Platform edition, and I’m yet to hear back about that on my support ticket.

Please can you post the correct link to the Standalone edition here?

@kevin.mcandrew1 if you will bother to read the previous replies, you will find the right download links.

@bionel, I don’t know if English is your native language, but just so you know, the way you’ve phrased your sentence does not come accross very nicely - happy to help explain further if necessary.

For your information, the above post from @vu.le at 22/09/2022 16:15 did contain a link that claimed to be for the standalone version earlier, but it looked exactly like the link I’d already been sent, which downloaded the Platform edition, and in any case clicking the link failed to initiate a download for me. You’ll notice also that the post has been edited twice, and the link has since been removed (with no clear explanation of why).

In an earlier post from @vu.tran at 22/09/2022 09:00, the advice to get Standalone edition is to login to TestOps and download from there, but as the screenshot shows, there is only the choice between Studio and Runtime. Studio downloads the Platform edition and there is no obvious way to download Standalone edition.

Similarly, the post from @Russ_Thomas at 21/09/2022 15:25 appears to link to a Git Hub page that again links - I beleive - to the Platform edition.

If I’m missing something, and the Standalone edition link is present above then I’m happy for this to be pointed out to me in a polite (and preferably specific) way, but so far I’ve found your post to be not particularly constructive (like I say, no problem if English language isn’t a strong point of yours).

@kevin.mcandrew1 english may not be my native language, but usually i read from top to bottom.
if you will try that, you may find (another) one post mentioning git.
hint: is the third post on this topic.
ignorance is not a bliss. have you clicked on it and looked at available artifacts?

@bionel I haven’t got the time to guess what download link I should be using, or to go with what someone ‘thinks’ is the case - I just need to know what the download link is for the Standalone edition - I don’t think that’s an unreasonable expectation.

The link you’ve suggested is very similar to the link I’d already tried (with no clear indication that it is the Standalone edition in the path or filename) and I simply don’t have the time to guess or do this by trial and error.

I gave you the benefit of the doubt earlier in how you were talking to me, in case it was a language issue, but you appear unrepentant, which is a shame. I don’t think using sarcasm or suggesting I’m ignorant is a good look for you, and it certainly doesn’t meet the community guidelines, one of which explicitly states “Be kind to one another”, but ultimately it’s your choice I guess - I would hope you’re better than this.

Is that hard?

For Mac i am not sure which one is needed, I am not using it, but obviously is one without PE in the name.
If you don’t have time to click a link, why do you think somebody from the community have time to do the research for you?
(side note, i already tried. if you don’t trust me wait for an official answer or open a support case)

Hi @kevin.mcandrew1, thank you so much for making your opinion clear and transparent. It’s very helpful and crucial to provide the whole context for an open and public audience in order to suggest/support you. As I am aware, your Support ticket (as you are our paid customer) are being processed and hopefully our solution has solved your issue and you can continue working with our Katalon products.

Hi @bionel, thank you for your always dedication to help users find their solutions. We appreciate your work and understand that your intention is trying to help.

From the community management view, more conversations mean involved parties understand more about the context and what is the best solution for each situation. In this particular topic, we acknowledge that the new change is overwhelmed with lots of information (new platform and new brand). This tells us that we have room to improve our outbound announcements/conversations, especially on the public place with many people from different backgrounds like Katalon Community. At Katalon Community, we want to ensure that our place is safe, professional, constructive and fun for everyone as described in our Community Guidelines - Katalon Community. We promote and encourage all members to:

:heart_decoration: Be kind to one another

Everyone deserves a positive experience on Katalon Community; please don’t post or send anything defamatory, obscene, infringing, harassing, discriminatory, or threatening to other members, whether through the community’s public areas or via Private Messaging (PM).

I hope we all align with the Guidelines and all contribute to the growth of Katalon Community for all stakeholders. Please let me know if you need anything from my side.

Thank you and have a great week ahead!
Vu Tran

Hello,

I have two subjects related to KRE 8.5.0,@vu.le @vu.tran @duyluong can you help me please:

  1. It seems that the new version does not recognize custom keywords.
    I receive the following error:

Reason:
com.kms.katalon.core.exception.StepErrorException: groovy.lang.MissingPropertyException: No such property: CustomKeywords for class: Login
at com.kms.katalon.core.main.CustomKeywordDelegatingMetaClass.throwError(CustomKeywordDelegatingMetaClass.java:101)
at com.kms.katalon.core.main.CustomKeywordDelegatingMetaClass.invokeStaticMethod(CustomKeywordDelegatingMetaClass.java:73)
at Invalidate_Cache.run(Invalidate_Cache:19)

  1. It seems that parallel running of test suites (with parallel running configured from Collection Suite) on version 8.5.0 also not working. Can you help to fix this situation? Also in parallel running it seems that my methods/keywords are not recognized.

Thank you,
Vlad

Hi @vlad.croitoru, thank you for sharing this with us.

Unfortunately, for our support policy, Katalon is not responsible for requests to create test scripts or custom keywords. However, let’s see if other community experts are able to help you.

Have you run the same tests with the previous version 8.4.0? It would be helpful if we can have screenshot/clip/log for this problem.

Please let me know if this works for you.

Hello @vu.tran ,

Sorry, but maybe I was not so explicit. I have some keywords created that I use in my testcases. For example a Login method. So, Katalon is not responsible for the good behaviour of keywords when test are runned with KRE (but the same tests runned for KSE are working well) ?

The last version when I tried to run in parallel is version 8.0.5 where from a Collection with 2 ts : TS1 and TS2 each ts with only one tc (actually same testcase) first ts TS1 runned successfully but the second one had errors.

For version 8.5.0 i receive for the scenario mentioned above the following error for both testsuites, it seems that this version of KRE does not recognize keywords :

2022-09-27T19:08:31
1664294911865
69
ERROR
com.kms.katalon.core.logging.XmlKeywordLogger
logMessage
1
No such property: CustomKeywords for class: Login
1
false
groovy.lang.MissingPropertyException
groovy.lang.MissingPropertyException: No such property: CustomKeywords for class: Login
at Login.LoginMethod(Login.groovy:40)
at Login.invokeMethod(Login.groovy)
at com.kms.katalon.core.main.CustomKeywordDelegatingMetaClass.invokeStaticMethod(CustomKeywordDelegatingMetaClass.java:55)
at CWPTP-274 - Personal_Agenda_Validation.run(CWPTP-274 - Personal_Agenda_Validation:19)
at com.kms.katalon.core.main.ScriptEngine.run(ScriptEngine.java:194)
at com.kms.katalon.core.main.ScriptEngine.runScriptAsRawText(ScriptEngine.java:119)
at com.kms.katalon.core.main.TestCaseExecutor.runScript(TestCaseExecutor.java:448)
at com.kms.katalon.core.main.TestCaseExecutor.doExecute(TestCaseExecutor.java:439)
at com.kms.katalon.core.main.TestCaseExecutor.processExecutionPhase(TestCaseExecutor.java:418)
at com.kms.katalon.core.main.TestCaseExecutor.accessMainPhase(TestCaseExecutor.java:410)
at com.kms.katalon.core.main.TestCaseExecutor.execute(TestCaseExecutor.java:285)
at com.kms.katalon.core.common.CommonExecutor.accessTestCaseMainPhase(CommonExecutor.java:65)
at com.kms.katalon.core.main.TestSuiteExecutor.accessTestSuiteMainPhase(TestSuiteExecutor.java:151)
at com.kms.katalon.core.main.TestSuiteExecutor.execute(TestSuiteExecutor.java:106)
at com.kms.katalon.core.main.TestCaseMain.startTestSuite(TestCaseMain.java:185)
at com.kms.katalon.core.main.TestCaseMain$startTestSuite$0.call(Unknown Source)
at TempTestSuite1664294882256.run(TempTestSuite1664294882256.groovy:36)

No such property: CustomKeywords for class: Login

Much appreciated if you have a clear answer and any workaround that can help.

Thank you,
Vlad

Hi @vlad.croitoru, thank you for your response. As we understand, you can run smoothly with KSE but not KRE, correct?

One of the reasons groovy.lang.MissingPropertyException: is thrown when you are using a variable outside of its scope or you haven’t defined that variable.

You could help check all the steps with the instruction in this docs Introduction to Custom Keywords | Katalon Docs

You are using version 8.0.5, would you mind trying with 8.4.0. You can find the downloadable link here. We would like to check if the problem persists in the later versions or not.

You can also provide us your project with keywords so we can see if we are able to reproduce the problem.

Thank you.