[New Release] Announcing Katalon Studio 9.0.0

I don’t even see an option to upgrade… it says i’m upto date with v8.6.8. Don’t tell me I need to reinstall a new version of katalon?

1 Like

Tagging one of our Katalon Studio Product Manager here @xuan.tran who may be able to answer your question.

1 Like

@ashraf.madina is right, I am also not able to update new version from katalon studio update option

Great initiative ! this step will improve quality of product as well as user experiance :smiley:

Hi @ashraf.madina, @atul.rai,

Since 9.0.0 has some major changes regarding Java and framework upgrades, we’re not allowing in-app upgrade and recommend downloading 9.0.0 from the website.

Besides, when upgrading from 8.x to 9.0.0, you might need to perform some additional steps for a smooth transition. For more details, see Migrate Katalon Studio from 8.x to 9.0.0.

I hope this info will be helpful, and if you have any feedback using Studio 9.0.0, don’t hesitate to leave a comment and let us know.
Happy testing,
Xuan Tran

2 Likes

Please do not force us to open the Studio Assist web link when closing the popup. The popup is bad enough, but opening a web page when I click the X is beyond the pale.

1 Like

+1

I see this popup everytime I stop and restart the Katalon Studio v9.0.0.

Please do not ask me to “learn more here” repeatedly.

1 Like

Hi there @clif.molina and @kazurayam,

Thank you for voicing your opinions on the StudioAssist prompt, I will be tagging @xuan.tran from our Katalon Studio team here so that she could take your feedback into consideration.

Thanks.

1 Like

Hi, will there be a webinar on this?

I am using BDD, Can there be a step by step guide on how to upgrade to 9.0 please?

1 Like

Thanks @clif.molina and @kazurayam for your feedback, we’re really appreciate this and we’ll fix it in our upcoming releases.

Hi @naomy.arnold,
If you are using BDD, then this section will be helpful for you: Migrate Katalon Studio from 8.x to 9.0.0 | Katalon Docs

@xuan.tran

I added it here , however the CucumberGlueGenerator.addDefaultPackages(); is UNDERLINED. does that mean there is an issue?

  • Is there anything else I need to do? Do I need to add @BeforeTestCase anywhere else?

  • This is the ERROR I see now and I do not understand it… It was passing before this.

I have this exact same issue. Very strange that what we are required to add does not work.

Resolved it myself, I had to add
import com.kms.katalon.core.cucumber.keyword.internal.CucumberGlueGenerator

Nothing was documented for this requirement.

Dan

2 Likes

I downgraded since I could not find any documentation on this. I will go back to 9.0 and add this.

@danpoleary thank you

@Eve_2024 @katalonstudio6 Can you add more documentation for above please and let me know. Thank you

Tagging folks from our Technical Writing team here so they can look more into this @antoine.touch @hao.le and @marjorie.chua

Thank you for the heads up Albert! We’ve created a ticket with based on this feedback and will address it as soon as we can.

1 Like

A post was split to a new topic: [KS 9.0.0] Blank error popup when saving captured items, and other errors with duplicated items