New formatter kills plugin

I have installed the Chrome plugin version 3.6.14 and am trying to add a new formatter.
As soon as you make a change, the plugin gets corrupted and you get the “This extension may have been corrupted” message and can repair the plugin.

I have added two new lines to the index.html file for the option as well as importing my newly created js file - same as sample file with changed name on first line, but the plugin died.

<option value="new-formatter-test">test</option>
<script type="text/javascript" src="js/katalon/newformatters/test.js"></script>

Then i have kept everything as it was installed and made the following change to the …\newformatters\sample.js file and again the plugin died.
content += ’ 3 ’ + command.command + ’ | ’ + + ’ | ’ + command.value + ‘\n’;

Would be great if you could let me know about what I am doing wrong.


-edit fixed formatting

Could you please share the source code?

Thanks for the quick reply.
Below is the most minimal change which kills the plugin. Have taken the original file and just extended the content.
Had to rename from js to txt for upload.

sample.txt (334 Bytes)

You need to define newFormatters.test function for the new test formatter.

As discussed, I had done that, but it failed.

The attached file is the modified ‘original’ file from the plugin, using the “Samples for new formatters” selection.
Just copy the file to to the “newformatters” folder and export using the sample. This will cause the problems.

I did it and the plugin still ran well.

I do not understand. I have tried it out at work now and have the same issue.
All I did was add some text to the beginning of the content line in the sample.js file, open Katalon in the Chrome browser and the window disappeared and the plugin again is corrupt.



Ok, saw that there is an error logging feature:


I have played around with it a bit more, but still not getting anywhere. Not sure why port 50000 is an issue.
At home I have a completely clean install of windows 10 pro and it fails.
At work I have windows 10 enterprise with admin rights and it fails.
I have added a firewall rule for port 50000, just in case, but it still fails.

Why would the unmodified js file work, but as soon as you add a couple of test characters, it fails?

Is there anything else I need to do/set to get this working?

Below is another exception i am getting:

Has anyone got an idea and can point me in the right direction to make this work?

You can ignore WebSocket errors.

How did you install the plugin? Did you modify index.html file? If possible, please zip the source code and send it to me so that I can try it myself.

First I changed the index.html file was well, but when that did not work, I started only modifying the js file, which also failed.

The “sample.js” file has been renamed to “.txt” for upload to work.
sample.txt (329 Bytes)

I have installed it via the following link:

Hi, was wandering if you have any update on trying out my files?

Please look at this formatter from New Relic team

Hi. I’m having this exact same issue. Any change made to index.html flags the plugin as corrupt. To test, I changed the sample.js file name to test.js in panel\js\katalon\newformatters; opened the file and changed newFormatters.sample to newFormatters.test; and then updated every occurrence of sample to test within index.html. I made no other changes. Plugin fails.

Edit: I wanted to add, if I revert all changes, the plugin goes back to working just fine.

Second Edit: I opened panel\ js\katalon\newformatters\nrsynthetics.js. At the end of the very first commented line, I added an r. That’s it. A single r. I made no other changes. I saved the file, tried to open the plugin, and it was immediately flagged as corrupt and closed. I removed the r, saved the file, and the plugin opens with no issues.

@devalex88 Are you able to assist?