My Test is broken - Form not being submited properly

Hi there,

I’m having trouble with this login form at using Katalon studio.

The expected behavior is that I’m able to enter my username and password, and be taken to a page to enter further details such as age, sex and location.

With Katalon, I’m able to fill in the forms as expected but upon submission, it has taken me to a different page.
Using the developer tool, I was able to check no cookie has been set after the login.

To replicate this, please use this dummy account I created:
Username: testkatalon
password: testtest2

My code:


WebUI.enableSmartWait()‘Object Repository/Page_Scratch - Imagine Program Share/span_Sign in’))‘Object Repository/Page_Scratch - Imagine Program Share/input__username’))

WebUI.setText(findTestObject(‘Object Repository/Page_Scratch - Imagine Program Share/input__username’), ‘testkatalon’)

WebUI.setEncryptedText(findTestObject(‘Object Repository/Page_Scratch - Imagine Program Share/input__password’), ‘YsxTccsmuDrYK6lYkm3X/Q==’)‘Object Repository/Page_Scratch - Imagine Program Share/span_Sign in’))‘Object Repository/Page_Scratch - Complete your Registration/button_Get Started’))

WebUI.selectOptionByValue(findTestObject(‘Object Repository/Page_Scratch - Complete your Registration/select_January’),
‘3’, true)

WebUI.selectOptionByValue(findTestObject(‘Object Repository/Page_Scratch - Complete your Registration/select_2019’), ‘2017’,
true)‘Object Repository/Page_Scratch - Complete your Registration/label_Male’))‘Object Repository/Page_Scratch - Complete your Registration/label’))

WebUI.setText(findTestObject(‘Object Repository/Page_Scratch - Complete your Registration/input__usergenderOther’), ‘Student’)

WebUI.selectOptionByValue(findTestObject(‘Object Repository/Page_Scratch - Complete your Registration/select_Select countryUnited States of Ameri_42de56’),
‘au’, true)‘Object Repository/Page_Scratch - Complete your Registration/div_Personal InformationThis information wi_6e7e22’))


Hi @NickW680

What version are you using ?


nothing is not broken, registration is done only once after that you will log in as your credentials

Tried both 7.0.0 Build 1 RC2 and 6.3.3, same result

Hi @NickW680

I tried it with 7.0.0 RC2 and here’s the result:


Do your test express the same behavior ?


after once registered success with this script to log in



    String title = WebUI.getWindowTitle()
    println title'Object Repository/BrokenTest/Page_Scratch - Imagine Program Share/span_Kirjaudu sisn'))

    WebUI.setText(findTestObject('Object Repository/BrokenTest/Page_Scratch - Imagine Program Share/input__username'), 'testkatalon')

    WebUI.setText(findTestObject('Object Repository/BrokenTest/Page_Scratch - Imagine Program Share/input__password'), 

    String css = "#navigation > div > ul > > div > div > form > div.flex-row.submit-row > button"
    TestObject to = new TestObject("Object")
    to.addProperty("css", ConditionType.EQUALS, css, true)```