Mobile APP events malfunction

Hi there,

I’m currently using Katalon Recorder from Katalon Studio to create test cases for a mobile APP.
However, a simple login test case is not working as expected.

The tap event on Login button is not being triggered and set text event on username field is not working properly (Katalon set the text 800800768 instead of 800800800).

Does anyone have any clue about the possible reasons of this strange behaviour?

Thank you in advance,
Best regards,
Iuri

Windows 10
Katalon Studio 8.0.1
Appium 1.21.0 (npm)

Please see this how-to for posting your issues:


As an example the appium.log file would give our mobile experts a starting point.
It should be in the root folder of your Katalon project.

Hi Dave,

You’re absolutely right about it.
Please, find the appium.log attached with this post.

As I said before, one of the malfunction is happening with set text event that is setting 800800768 instead of 800800800:

e[35m[HTTP]e[39m e[37m-->e[39m e[37mGETe[39m e[37m/wd/hub/session/b9eda7d2-51b2-49da-9f95-d99c7d79b5f1/element/287c9221-3903-4d90-b816-f44367653ea7/locatione[39m
e[35m[HTTP]e[39m e[90m{}e[39m
e[35m[W3C (b9eda7d2)]e[39m Driver proxy active, passing request on via HTTP proxy
e[35m[WD Proxy]e[39m Replacing sessionId 5eee935a-c68e-4fcd-bda6-2c2cf008a095 with b9eda7d2-51b2-49da-9f95-d99c7d79b5f1
e[35m[HTTP]e[39m e[37m<-- GET /wd/hub/session/b9eda7d2-51b2-49da-9f95-d99c7d79b5f1/element/287c9221-3903-4d90-b816-f44367653ea7/location e[39me[32m200e[39m e[90m40 ms - 77e[39m
e[35m[HTTP]e[39m e[90me[39m
e[35m[HTTP]e[39m e[37m-->e[39m e[37mPOSTe[39m e[37m/wd/hub/session/b9eda7d2-51b2-49da-9f95-d99c7d79b5f1/element/287c9221-3903-4d90-b816-f44367653ea7/cleare[39m
e[35m[HTTP]e[39m e[90m{"id":"287c9221-3903-4d90-b816-f44367653ea7"}e[39m
e[35m[HTTP]e[39m e[37m<-- POST /wd/hub/session/b9eda7d2-51b2-49da-9f95-d99c7d79b5f1/element/287c9221-3903-4d90-b816-f44367653ea7/clear e[39me[32m200e[39m e[90m132 ms - 14e[39m
e[35m[HTTP]e[39m e[90me[39m
e[35m[HTTP]e[39m e[37m-->e[39m e[37mPOSTe[39m e[37m/wd/hub/session/b9eda7d2-51b2-49da-9f95-d99c7d79b5f1/element/287c9221-3903-4d90-b816-f44367653ea7/valuee[39m
e[35m[HTTP]e[39m e[90m{"id":"287c9221-3903-4d90-b816-f44367653ea7","text":"800800800","value":["8","0","0","8","0","0","8","0","0"]}e[39m
e[35m[HTTP]e[39m e[37m<-- POST /wd/hub/session/b9eda7d2-51b2-49da-9f95-d99c7d79b5f1/element/287c9221-3903-4d90-b816-f44367653ea7/value e[39me[32m200e[39m e[90m58 ms - 14e[39m
e[35m[HTTP]e[39m e[90me[39m

Thank you in advance once again,
Best regards,
Iuri Figueiredo

appium.log (25.5 KB)

Hi @iuri.figueiredo,
I see your using appium v1.21.0 which is good.

Regarding the “tap” event not working you may need to use the “Capture Object” button. My best practice is to use “Capture Object” after each page load.

Sorry not sure about the text event.

Thanks,
Dave