Log Viewer results significantly delayed

Steps:

  1. Have a simple test case that takes over an hour to run.

Results:
Within several minutes, the “Log Viewer” gets significantly delayed in relation to the actions being performed on the website. After about 20 minutes, Katalon started becoming unresponsive from falling behind too much.

Additional Notes:
It’s a simple simple script that opens a website in Chrome, presses about 20 buttons using WebUI.click(findTestObject()) function, waits 20 seconds, refreshes website and does the same. I would like this script to be able to run for a couple hours, but after 30 minutes theres a huge lag with eventual lock up.
Disabling logging may resolve this, but I don’t have enterprise edition in order to use this function.

Regression Info:
I’ve had same issue with Katalon 6.

Please let us know how would your work be affected if this issue has not been resolved?

  1. I can continue my job, but my performance is lower than expected

Operating System

MacOS Catalina 10.15.6 on 2019 MacBook Pro

Katalon Studio Version

7.6.2 (build 205)

We need more information about your project and problems.

Just a few guesses…

Disabling “Smart Wait” may help:


WebUI.click() is sometimes faulty.
Why not you try clicking the element using JavaScript?


This may occur when you have too many messages from the executed Test Case, eg. by WebUI.comment(msg) or by “Step Execution Log”. You should comment out verbose WebUI.comment() calls as much as possible


You have an alternative way of decreasing Test Cases’ “Step Execution Log” messages.

Katalon Studio would not emit any verbose “Step Execution Log” messages for Keywords. I recommend you to transfer your codes in the Test Cases (Groovy scripts) into the Keywords (Groovy classes). Especially you should transform the codes which are repeatedly executed. Once you have implemented it as Groovy classes, you will replace the original codes in Test Cases with codes that invoke methods of the new Classes. Then the amount of “Step Execution Log” will become less. Less messages will make Log Viewer responsive.

Thank you for the quick reply.

Disabling “Smart Wait” may help

I actually already had it disabled it as it was giving me other problems previously

Katalon Studio would not emit any verbose “Step Execution Log” messages for Keywords. I recommend you to transfer your codes in the Test Cases (Groovy scripts) into the Keywords (Groovy classes).

THIS! It was actually a lot easier to implement than I expected. After transferring the while loop into a Keyword, nothing inside the while loop gets logged. I’ve now been able to successfully run my code for several hours continuously without performance issues. Thank you!