Loading Project and Katalon Studio is stuck at "Generating Global Variables"

I opened Katalon Studio today to continue making test cases and I was given a loading screen upon selecting my project where it hasn’t moved beyond “Generating Global Variables”

Unsure what other information that I can provide, please let me know what I can add to better help determine what the issue is.


I think @Brandon_Hein has some tricks for cleaning up a project. Let’s see if we can’t make a tips&tricks article that might help here.

Yea, anytime the studio has a problem loading a project, I find that doing the following seems to help:

In simple terms, what it does is remove all of the binaries from the project, then lets the studio recompile all of your project code from scratch the next time you open it.

If it turns out that this helps OP, I’ll go ahead and post a tips and tricks topic with more detail.


How do you do it?

Delete these folders from your project folder, then re-open the project in the studio:

In reality, I’m not sure doing this is much different than doing a Project > Refresh.


hello @Brandon_Hein ,
i have the same problem but on mode cli it’s about writing permission on the project folder but i am sure that i am running test as administrator :thinking:

Delete folder: bin Delete folder: Libs Opening project file: C:\workspace\qa-ccfn\Portal katalon project.prj Request sent successfully. !ENTRY org.eclipse.core.resources 2 10035 2019-02-17 15:24:54.138 !MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes. Starting Groovy-Eclipse compiler resolver. Specified compiler level: unspecified 167 2.4.7.xx-201611170128-e46 = ACTIVE Parsing custom keywords... !ENTRY org.eclipse.jdt.core 4 0 2019-02-17 15:25:04.743 !MESSAGE Invalid ZIP archive: C:\Users\ahmed_b\Downloads\Katalon_Studio\Katalon_Studio\configuration\resources\lib\jzlib-1.1.3.jar Generating global variables... java.lang.InterruptedException: System could not generate internal.GlobalVariable file normally. Please check your writable permission in folder: C:\workspace\qa-ccfn. at com.kms.katalon.controller.GlobalVariableController.waitForGlobalVariableClassFileAvailable(GlobalVariableController.java:79) at com.kms.katalon.controller.GlobalVariableController.generateGlobalVariableLibFile(GlobalVariableController.java:64) at com.kms.katalon.controller.ProjectController.openProject(ProjectController.java:105) at com.kms.katalon.execution.console.ConsoleMain.getProject(ConsoleMain.java:248) at com.kms.katalon.execution.console.ConsoleMain.findProject(ConsoleMain.java:153) at com.kms.katalon.execution.console.ConsoleMain.launch(ConsoleMain.java:88) at com.kms.katalon.console.application.Application.runConsole(Application.java:76) at com.kms.katalon.core.application.Application.runConsole(Application.java:76) at com.kms.katalon.core.application.Application.start(Application.java:59) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610) at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

1 Like

Hi @ahmd.belhoula

Can you move the project to another folder that doesn’t need permission to see if it works ?

Regards !

hi @ThanhTo ,
thank you for the answer I check the permissions on the folder ,I tried as you ask but the problem remains the same.

Regards !

1 Like

any solution on this I too have the same issue, and my katalon version 5.10.1. I try deleting those files and still having the same issues.


I had the same issue. Katalon Studio version 5.10.1 & 5.10.0

I solved my issue by: just removing other ".glbl files (other than default) out of the “profiles” folders.
restarted Katalon Studio and it opened.
–> I then pasted by my other ".glbl files back in the profiles folder
–>went back into katalon studio and refresh
–>I closed Katalon Studio and reopen Katalon Studio and error was gone.

Thanks, GCC.

@devalex88 The above is unlikely to fix the GString issue I mentioned but it might point to more clues?

I attempted @Brandon_Hein method by deleting the mentioned folders however that didn’t resolved the error.

@devalex88 you are correct this dosen’t fix the GString issue because the issue came back and my work around is to remove all the other “profiles” and reopen the project and the errors goes alway.

Sorry, but deleting files on disk created via a Katalon UI component is not a workaround. Neither is it reasonable.

The bug stands. It needs to be fixed.

The most annoying this is, if you fix the variables on Katalon’s behalf, it’ll just overwrite them again and break itself again.

I’m waiting patiently (but that’s limited!) for 5.11.0



I found my issue, I double check my lib/internals/GlboalVariables.groovy file and there was a typo.

@ahmd.belhoula or @brandon.evans you can double check this file and see if there’s any errors in your variable.

Also I had a lot of profiles, but with the workaround I did, I don’t know how katalon studio still opens the projects.


Just for the record, we’ve made some improvements in 6.0.6. If possible could you please help us verify this issue?

It’s working now i am on 6.1.0 now.


I’m still having this issue. Tried on different versions (including 6.1.0 and 6.2.1).

cmd screen shows:

Parsing custom keywords…
Generating global variables…

If I wait long enough, the Project gets eventually started, but it takes a couple of minutes, and thus is very annoying…

Please look into this. Let me know if any more information is required.


1 Like

Thank you for let us know. Was it intermittent or happening all the time? If possible please send us (info@katalon.com) the project for investigation.


Thanks for the quick response!
It is happening all the time, and with all my Katalon test cases.
I will send you a part of the project for investigation.