KRE output do not support chinese character?


I try to run KRE in windows cmd, but the output in Chinese was a mess,what can I do to make it display right?

KRE output characters into the console using character-encoding UTF-8.

On the other hand the cmd.exe (Windows DOS prompt) on your PC is possibly using some character-encoding other than UTF-8.

You need to setup cmd.exe process to regard character stream from KRE as UTF-8. You can change it by CHCP 65001 command. See

In the commandline you want to do:

$ CHCP 65001
$ katalonc -noSplash -runMode=console -projectPath=....

Alternatively you can change the default codepage setting of cmd.exe by editting Windows Registry. Please do google search with key “cmd.exe codepage UTF-8 registry” to find out how to

1 Like