KRE 7.3.0 fails to load plugins, claims invalid api key

Whenever I try to run my test suite using KRE instead of Katalon Studio it tells me my API key is invalid to reload plugins.

First: I noticed it says at the start of the run 'INFO: Katalon Version: 7.2.1, does this mean my KRE is running an older version of Katalon?

Secondly: I’ve tried to reload plugins from the web store, but I don’t think it will work even if the API key was validating correctly. I have many locally written plugins I need to use, and these work fine in Katalon Studio, but I don’t understand how I’m going to be able to import local plugins to KRE. Plus, it’s not reloading plugins from the web store.

com.kms.katalon.plugin.models.ReloadPluginsException: Unexpected error occurs during executing reload plugins under account: Invalid API key, please re-check your credential
    at com.kms.katalon.plugin.service.PluginService.reloadPlugins(PluginService.java:248)
    at com.kms.katalon.composer.handlers.ConsoleModeReloadPluginsHandler.reload(ConsoleModeReloadPluginsHandler.java:22)

Interesting note, when I try to run the test in KRE and it fails, when I go back to Katalon Studio the test fails immediately with:

Reason:
java.lang.Error: Unresolved compilation problem:
Groovy:unable to resolve class com.katalon.plugin.keyword.connection.DatabaseKeywords 

How can I set up database connection if I can’t set up database in KRE?

Hi @jlegault,
How did you get the API key?

1 Like

I’ve got two different ones listed under https://store.katalon.com/account#security as ‘Key1’ and ‘KRE Key’ Neither of these keys seem to work, as Katalon Studio auto loads them into the command line generator but when I try to run them with the KRE it just errors our and won’t let me update plugins.

I reinstalled and it is working now. I assume my issue was with a file not installing correctly: path too long errors were common as I tried to find somewhere I could install it.

1 Like