Keyword driven IE test case won't 'click' on button

Hi all, I’m using the keyword driven feature to execute a simple test case in IE. The test case is very simple; go to website, type in string, click search button.

My test passes, and I get no errors. However, it never ‘clicks’ the button, and simply stays on the same page.

I ran this same test in the other browsers and it worked fine. It’s only IE that is giving me this issue.

Could someone help me figure out what the issue might be?


Not sure if it is something to do with IE or not, however, I have had situations in which a button does not click properly in Chrome. For this, I have to write the XPath to just above the actual button. In my example below, I don’t create a path all the way to the button, but to the “div” parent above:


In other situations, I have to create the XPath all the way to the button, such as:

id(“DataModel_CancelDate”)/following-sibling::button[@class=“btn btn-default”]

As yet, I haven’t determined why click on the button one time but not for another.