Katalon test case hungs temporarily during execution

Hello all,
I have been trying to run a test case for the past 4 days but I haven’t been able to get rid of a random and strange delay.

My test case needs to do the following task in a loop 1000 times:

click a button
read a value
save the value in an excel cell
update counter

I can do the loop for about 20 to 50 times without any issues, I was even able to run the loop for about 200 times without issues.

However, sometimes it randomly hungs and debugging information just stops temporarily coming out from the debugging windows and then it continues until the next random delay.

I’m using the latest version of Katalon, updated my Chrome driver and Selenium as well, but the issue is still happening. I’m waiting a maximum of 10 seconds for the element to become visible. I’m actually seeing the element is there and Katalon is not reading it until the random delay is done.

I already modified Katalon settings to set the default wait time for elements to become visible to 5 seconds and most of the times my random delays are between 5 seconds and 60.

I see the random delay happens randomly and the console just shows things like:
Checking Object
Checking Timeout
Start action

But no errors and then it just continues.

I have also increased my RAM from 2 GB to 16 GB without any difference in my results.

Have anyone seen anything similar or perhaps have any idea about how I could narrow down the source of the problem better?

Thanks in advance

I’m going to take a wild guess…

It’s not your test, or Katalon, it’s something else entirely that is halting your system.

Have you tried looking at resources (Task Manager/Resource Monitor) to compare while the random delay occurs?

1 Like

I agree with Russ.

Something similar happened to me. I was checking load time of an element and writing it to an array. The test would run just fine for 100 or 200 repetitions, with 2 or 3 seconds for each iteration. But, when running the test for 1000 times, I would start to see 500 second delays. The cause was database recycling.

1 Like

Interesting Mate.

Daniel, try two things:

1 - Check your system is configured to be optimized for desktop applications (i.e. not server).

2 - Copy your stuff to an entirely different system. Run your test. Observe.

1 Like

Many thanks Russ and Mate for your responses. It is very hard to narrow down the source of this issue indeed.

I executed my test case in two different laptops with the same results.

I’ll focus on some other tests this weekend related to configurations and so on instead of Katalon itself and I’ll get back if I find anything interesting.

@10442-Russo @Mate Mrse

I solved my issue. It was related to the Katalon GUI somehow.

Executing my test case using the command line generator, solved all the random delays I experience when running a test case from the GUI.

My test case was able to do 10000 iterations (clicking a button and saving 10 fields to an Excel row) without any delay.

I hope someone can make better sense from this to locate the issue within the GUI and fix it.

However, if anyone has any similar problem, just try generating a cmd line and try if that solves any random delays.

My command line looks like:

katalon -noSplash  -runMode=console -consoleLog -noExit -projectPath="C:\Users\userKatalon Studio\Test\test.prj" -statusDelay=5 -retry=0 -testSuitePath="Test Suites/mycase" -executionProfile="default" -browserType="Chrome"

Reference: https://docs.katalon.com/katalon-studio/docs/console-mode-execution.html#use-consoleproperties-file


Excellent detective work, Daniel.

Please post a bug report (you can obviously link this thread) http://forum.katalon.com/categories/katalon-studio-bug-reports

1 Like

Russ Thomas said:

Excellent detective work, Daniel.

Please post a bug report (you can obviously link this thread) http://forum.katalon.com/categories/katalon-studio-bug-reports

Done! Thanks @Russ Thomas

Here is a link to the reported issue: http://forum.katalon.com/discussion/10543/katalon-gui-random-delays