Katalon Studio v 6, slowness in appium server start application command takes 60 secs to launch


#1

Appium 1.8.1
Node 10.15
Katalon v 6.1.0
Android 9

Its taking too much time to execute start application command “60-70” seconds on each tcs which includes appium server start & uiAutomator2 start.

This gives overall TestCase execution time of 2mins for login.

I tried with setting up appWaitActivity as *.

Can you please suggest to improve the application launcher fast.


#2

Hi @Selva_Guhan_Nagaraja,

You could also try setting the appWaitDuration (in milliseconds) desired capability. There are other Desired Capabilities that might affect timeout as well that you can try:

http://appium.io/docs/en/writing-running-appium/caps/

Hope this helps,

Chris


#3

Hi @Chris_Trevarthen,

Thanks for your response.

I tried setting up appWaitDuration as * & executed but still getting 25 seconds launch wait time for each test case in suite.
This completely delays the execution.

Can you please suggest for real device android apk what else to be need to setup.
image


#4

Hi @Chris_Trevarthen,

Also, please find the below appium logs which default waits after UiAutomator2 command execution for AndroidJunitRunner. 20000ms waiting for Automator2 online…

Cant we reduce or skip this wait for each time start application

e[35m[ADB]e[39m Successfully extracted 2225 strings from ‘C:\Users\Admin\Katalon Studio\MyEtisalat_FirstDemo\androidapp\My Etisalat_com.Etisalat.ETIDA.apk’ resources for ‘(default)’ configuration
e[35m[UiAutomator2]e[39m Starting uiautomator2 server 1.12.0
e[35m[UiAutomator2]e[39m Using UIAutomator2 server from ‘C:\Users\Admin\AppData\Roaming\npm\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-v1.12.0.apk’ and test from ‘C:\Users\Admin\AppData\Roaming\npm\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-debug-androidTest.apk’
e[35m[UiAutomator2]e[39m Running command: ‘adb -s PLEGAR1771809634 shell am instrument -w io.appium.uiautomator2.server.test/android.support.test.runner.AndroidJUnitRunner’
e[35m[UiAutomator2]e[39m Waiting up to 20000ms for UiAutomator2 to be online…
e[35m[AndroidDriver]e[39m Screen already unlocked, doing nothing
e[35m[UiAutomator2]e[39m UiAutomator2 did not start the activity we were waiting for, ‘com.Etisalat.ETIDA/com.Etisalat.ETIDA.home.activities.SplashActivity’. Starting it ourselves
May 15, 2019 10:48:57 PM org.openqa.selenium.remote.ProtocolHandshake createSessione[35m[UiAutomator2]e[39m Starting uiautomator2 server 1.12.0
e[35m[UiAutomator2]e[39m Using UIAutomator2 server from ‘C:\Users\Admin\AppData\Roaming\npm\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-v1.12.0.apk’ and test from ‘C:\Users\Admin\AppData\Roaming\npm\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-debug-androidTest.apk’
e[35m[UiAutomator2]e[39m Running command: ‘adb -s PLEGAR1771809634 shell am instrument -w io.appium.uiautomator2.server.test/android.support.test.runner.AndroidJUnitRunner’
e[35m[UiAutomator2]e[39m Waiting up to 20000ms for UiAutomator2 to be online…
e[35m[UiAutomator2]e[39m Starting uiautomator2 server 1.12.0
e[35m[UiAutomator2]e[39m Using UIAutomator2 server from ‘C:\Users\Admin\AppData\Roaming\npm\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-v1.12.0.apk’ and test from ‘C:\Users\Admin\AppData\Roaming\npm\node_modules\appium\node_modules\appium-uiautomator2-server\apks\appium-uiautomator2-server-debug-androidTest.apk’
e[35m[UiAutomator2]e[39m Running command: ‘adb -s deshell am instrument -w io.appium.uiautomator2.server.test/android.support.test.runner.AndroidJUnitRunner’
e[35m[UiAutomator2]e[39m Waiting up to 20000ms for UiAutomator2 to be online…
e[35m[AndroidDriver]e[39m Screen already unlocked, doing nothing


#5

Hi @Selva_Guhan_Nagaraja,

I think appWaitDuration is supposed to be a Number, so can you try setting it to something like 10000 (it’s in milliseconds) and see if it reduces the amount of time that the test waits to start up?

If that doesn’t work, you could try setting the appWaitActivity to actual launch activity of your app - if Appium knows it’s looking for a specific activity, it might find it faster (this is just a guess).

Hope this helps,

Chris