Katalon Studio not responding

I would suggest you to check with Katalon Developers on this forum. There might be just a configuration issue.

@ThanhTo @devalex88 @Alice Can you guys please help here.

1 Like

thank you so much for the help, manpreet.

also, if this could help, my test case has 113 variables and 303 lines of code

@Mateus_Gomes_Binatti I don’t think the number of Variables or Lines of code are culprit here. Lets wait and see what Katalon team has a solution for this ?

A very weird question ? Did you tried to reboot your computer and whats the configuration it has ?

@Mateus_Gomes_Binatti

Update your first post with ALL details pertaining to your system (OS, Katalon version, etc).

I will move this to the Bug Reports category.

@devalex88 @Dung_Ngo Can we have some heavyweight Kat heads take a look here? Thanks.

1 Like

@Mateus_Gomes_Binatti

Let’s try a few things:

First backup your files!!!

That’s so important I’ll say it again - Backup your files!!!

Determine if it is Computer/OS related:

Copy the whole project to another computer. Does the project behave okay there? If not, then the problem is likely inside your project or Katalon itself.

Determine if it is the project:

Start a new project. Does Katalon behave okay now? If so, it’s your project. If not it’s Katalon. (You could backup your projects and re-download Katalon and install again)

If it is the Project…

Start deleting profiles. Check Katalon after each deletion.
Let us know WHICH profile when it was deleted allowed Katalon to work correctly. @devalex88 will want to see it (and you still have a copy because you made backups, right? :slight_smile: )

4 Likes

@Russ_Thomas
hello, russ!
sure, i will do this right now!

dont worry, i have all on a git repository! haha. thanks for the advice!!

Determine if it is Computer/OS related:

i have the same issue in the computer that i used to work with, and my teammates give me another, but the problem persists!

Determine if it is the project:

ive created a new project and the problem persists!
ive already re-downloaded katalon, and tried older versions to see if the problem was the currently, but not.

If it is the Project…

the only profile is the “default”
image

In practical terms, 8GB of RAM is a little on the low-side for Win10 w/ Katalon. However, I do run my suites on the exact same setup without issue.

Just for reference, I use Win7 with 16GB RAM for Test Case development.

Did you try creating a new project on both computers? Did they both have the same issue?

One other question: On what version of Katalon did this problem first appear? I am wondering if it is worth trying an older version to see if the issue suddenly disappears (but not yet, let’s allow @devalex88 take a look at the rest of this thread first).

Empty it out. Write a simple test. What happens now?

One more thing…

  1. Disconnect your PC from the network
    1.a. PROVE you are disconnected from the network.
  2. Turn off ALL antivirus protection.
  3. Exclude your project folder and Katalon folders from Windows Defender.
  4. Open Katalon.
  5. Write a simple Test Case in a New project.

Post back the results (And turn your AV back on and reconnect to the network!)

1 Like

“Did you try creating a new project on both computers? Did they both have the same issue?”

yes, russ, i created a new project on both computers! same issue for both!

On what version of Katalon did this problem first appear?

first appeared on 5.10.1. ive already tried 5.8.6, .510.1 32 bit, 5.9.0.

Empty it out. Write a simple test. What happens now?

the file has the default configs, i cant delete and, always when i erase from “script view” and save, katalon put those lines back

<?xml version="1.0" encoding="UTF-8"?> default true

One more thing…

ive done all of this and the problem persists :frowning:

By “empty it out” I meant delete all the variables (not delete the file itself).

Yet another “one more thing”…

When you download another version, are you copying it OVER the broken install? Katalon is a self-contained, standalone system - meaning, you can install many copies at the same time.

If you did copy over the old system(s) then please try again but this time, install it separately and run it from the new install folder. Understood?

This is what makes me think of AV or WinDefender.

A while ago (back when Win10 was new), I moved a development system (node.js and NW.js) to a shiny new Win10 system. The whole thing behaved exactly as you described. On Win7 it worked perfectly. When I blocked WinDefender from accessing everything in the dev environment (including Visual Studio and the publish folders) suddenly it started working correctly.

How are the permissions set on your project folder?
Is your user account local? Or does it come from a domain controller?
Are you opening Katalon with the same user account?

When you download another version, are you copying it OVER the broken install?

i downloaded the version, extracted the files and opened the katalon.exe from the new folder.
thats correct?

This is what makes me think of AV or WinDefender.

yeah, thats a point. but here we dont use AV, and win defender isnt blocking katalon,

How are the permissions set on your project folder?

how i check this?

i use the admin account, and i am opening katalon with adm user.

Sorry, I’m out of ideas. I need to defer to @devalex88 et al.

1 Like

no problem, russ!
im so glad that you’ve tried to help me!

best regards, bro!

1 Like

Maybe I lied. One last thing…

Yes, correct. And this leads me to strongly suspect your system (computer/OS) AND all other systems in your network where you tried it.

Rhetorical question: where are all the other reports of users with a similar problem?

Something on your computer is messing with you (and Katalon).

p.s. I now no longer think this is a bug in Katalon (moving again).

1 Like

@Russ_Thomas


Thats the only report that looks like my problem.

This is so sad, i really dont know what to do :confused:

Sorry for this issue. Please help us isolate the root cause.

Enable heap memory report

You should see then a small widget on the bottom status bar that shows how much heap memory is being consumed.

Collect Java heap dump

This file will tell us exactly what were stored inside Katalon Studio’s memory.

Download Eclipse MAT.

Unzip, open it, and go to File > Acquire Heap Dump.

Make sure the file path points to a dedicated folder, because several files will be generated. Click Next, and then click Finish.

Then please send us (info@katalon.com) the *.hprof files.

2 Likes

hello @devalex88!

thats the heap value when i opened my test case!
image

i am sorry, i dont know how to use it, but theres not java process i guess?
image

Hello, guys!

To solve this problem, i have to:
Increase the memory on -Xms (katalon.ini);

Transfer all my variables from “Variables” to a Keyword Class, something like this:
public class MemberConstants {
//form variables
public static final String NAME_SELECTOR = “input.name”;
public static final String SEX_SELECTOR = “span[data-name=sexo]”;
}

Now, i call this variables from the scope, so:

inputReturn = CustomKeywords.‘genericosPessoa.campoInput.inputValue’(MemberConstants.NAME_SELECTOR, MemberConstants.NAME_VALUE);

Now, my IDE is working fine!

Thank you all!

1 Like

Is it “Test Case Variables”? Can I say that if you hadn’t done this step, KS would’ve been not responding?