Katalon Studio not responding during Android app test case recording on loading screens (Cordova app using Vue)


I am experiencing a freezing issue in Katalon Studio when attempting to record Android app test cases that include loading screens. Whenever the app displays a loading screen during the test case recording, Katalon Studio becomes unresponsive and freezes.

The app is generated using Cordova and is based on Vue + Vue Material.

Steps to reproduce:

  1. Open Katalon Studio and create a new test case for an Android app.
  2. Start the test case recording.
  3. Trigger a loading screen in the app by performing an action that requires loading data or resources, such as logging in or opening a new screen.
  4. Observe that Katalon Studio freezes and becomes unresponsive.

Expected behavior:

Katalon Studio should continue to function normally during test case recording, regardless of whether the app displays loading screens or not.

Actual behavior:

Katalon Studio freezes and becomes unresponsive during test case recording when the app displays loading screens.


At present, there is no known workaround for this issue. Restarting Katalon Studio appears to be the only solution to unfreeze it.


Please let me know if you need any further assistance or information.

@hldh214 I believe what you are seeing is the object capture screen that occurs after each action during the record process. If the device screen changes since the last object capture you can recapture by selecting the “Capture Object” button near the top left corner right next to the “Start” button. Not that if the screen needs a long time to load you may need to manually add a wait between tapping the button and taking the next action.

If I am misunderstanding the issue please add some more detail of what the emulator is doing when it freezes.


@kreno Thank you for your reply.

I am aware of the “Capture Object” button that can refresh the device view. Perhaps I used the word “freezes” incorrectly, as “not responding” would be more appropriate in this case. The entire “Mobile Recorder” window becomes unresponsive when I hover over loading objects such as the close button.

Your response gave me inspiration, and I tried to reproduce the issue again. It appears that the issue only arises when attempting to right-click on an object that is no longer present. For example, when the loading screen appears and disappears after a few seconds, and the device view continues to display the loading screen, if I click “Capture Object,” the device view will be refreshed and everything will work fine. However, if I try to perform an action on the already disappeared object, such as right-clicking and selecting “Wait for Element Present,” the “Mobile Recorder” window will suddenly become unresponsive. This is the issue I am referring to.

its all depends on the hardware(System-Laptop/Desktop) configuration. emulator and simulator are taking lot of time. you can use physical device instead of emulator and simulator.

1 Like

Hi @hldh214 ,
katalon is using the Appium server to capture the objects from your mobile Device.
for each action you do on your mobile, you have to click on the Capture objects button.
if not the mobile spy screen will only show you the previous screen of your mobile.after clicking on the Capture object button only it will load the screen and the objects in the screen.
Note this is not only applicable to screens(technically Activities) but also applicable while you select a dropdown too in a mobile application.

Hi @bharathi.a ,

As I mentioned in my previous reply, I am familiar with the “Capture Object” button that refreshes the device view in Katalon Studio.

My specific goal is to capture objects during the loading screen phase and detect when the loading process is complete before proceeding with the next action. However, if I use the “Capture Object” after each action, I may not be able to obtain the locator (for example, XPath) for my loading screen.

While loading please click on capture object button it will load the object of the loading screen.

@hldh214 Sorry, I misunderstood your original ask. You can always create the objects manually if you know the identifiers you wish to use.

I think the issue you are seeing is that the objects are captured when loading but when you try to tap the close button during the loading screen during a recording that screen no longer exists. Katalon will hang when looking for that object that existed when the objects were captured. If you wish to use the record action to capture the loading objects you will need to trigger the loading screen again by navigating through the simulator to repeat that screen while the recorder is waiting. I included a screen recording of trying to capture an object that no longer exists and triggering it again to allow the recorder to interact with it.

@kreno Thank you for your reply, I really appreciate it.

I tried your suggested method and it worked great. However, I’m still experiencing an issue with my original case where I’m unable to “right-click” on the missing object in the “ALL OBJECTS” tree located in the middle of the recorder window. This is causing a “not responding” issue. It could be related to Windows since “not responding” seems like a Windows feature, similar to BSOD (Blue Screen of Death) :wink: .

Anyway, your method provided a different solution to my original problem of capturing the non-existent object. As a result, I will be closing this thread as resolved. Thank you once again.