Katalon Studio does not recognise externally added "folders"

Katalon Studio v8.3.0
macOS 12.3.1

My test case script creates a folder <projectDir>/store.

Before executing the script, the Test Explorer of Katalon Studio did not show the store folder (obviously because it is not yet there).

I ran the test case. I confirmed that the store folder has been created by ls -la command in Terminal.

I did “Reflesh” operation on the Tests Explorer.

Then, the store folder DID NOT come up in the Tests Explorer tree view.

Even more. I stoped the project, reopened the project. Then the store folder is displayed.

Previously I raised a similar issue as this:

where I reported that “a file” is not shown. This issue has been fixed a t v8.3.0. I have confirmed that a “file” is displayed by “Reflesh”.

This time, I am saying a “folder” is not shown.

I re-tried this, and found, in v8.3.0, a folder <projectDir>/store created by a Test case was displayed in Tests Explorer by Reflesh operation.

It seems that the “Reflesh” sometimes works and sometimes doesn’t. I do not know precisely when.

Hi @kazurayam,

There are 2 cases for “Refresh” in Test Explorer:

Please try the second one and let me know if it works.

Nam Nguyen.

This strictness just confuses me.

As I wrote in the the following post, I would rather KS to auto-save everything and auto-refresh everything all the time, as most IDE’s does (VSCode, IDEA, …)

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.