Katalon Store - Explore Plugins for Katalon Studio


#1

This is a companion discussion topic for the original entry at https://store.katalon.com/product/56#qa-content

#2

Is this plugin helpful for Windows app screenshot as well?
I am using KS with winium to automate windows app


#3

Hello Katalon Team,

I am facing an issue with this plugin. After installing the pluglin when I tried to reload plugins I got below error.

27%20AM

But after clicking Ok and trying again it worked without any error.

02%20AM

Now it shows the plugin is installed but I still can’t see it in Custom Keywords dropdown.

02%20AM

53%20AM


#4

@devalex88 @ThanhTo @Dung_Ngo The issue is still happening. How this can be fixed ?


#5

Still no fix on this issue


#6

@manpreet.mukkar, please send the error log file. You can find it under Help > Error Log


#7

@huynguyen I just sent you log file in direct message.


#8

Thank you. I have received the log file and tried to reproduced the issue. However, the plugin custom keywords do show up in Custom Keywords dropdown on my side (Katalon v6.1.3). Does the custom keywords not show for all plugins you’ve installed or just some of them? If so, please help by naming specifically which one of them.
Regards.


#9

Hello @huynguyen

I just tried to install the “ashot” plugin again and I got the same error.

36%20AM

I clicked OK and did reload plugin again and it didn’t give me an error but when I try to use this keyword in a test case I can’t see the ashot keyword in Keywords dropdown. I have attached the screenshot as well for Custom Keywords dropdown. It’s only happening with this plugin. Other plugins work fine for me.

12%20AM 06%20AM 58%20AM 50%20AM 21%20AM 11%20AM


#10

Hi @manpreet.mukkar,
The issue now occurs from my side when installing “ashot” plugin. We will investigate it and get you noticed asap.
Regards.


#11

@huynguyen Thanks a lot for your help. I really appreciate the work you and your team is doing.


#12

We have fixed the issue. Please reload plugins and check.


Reload plugins not work as expected
#13

@huynguyen Its working now. I can see the plugin in custom keywords dropdown.


#14

thank you for quick fix


#15

Hi, it seems that takeWebElementsScreenshot raises an error
“org.openqa.selenium.JavascriptException: TypeError: $ is not a function” any idea why?


#16

Hello, does this plugin support mobile ?