Katalon SSH key generation is not compatible with new Gitlab version security protocol

so, the issue is already addressed in the recent version, isn’t?
I hope you don’t expect to be backported to 8.x
if, for some reason, you really need an older version, e.g due to:

you can disable the git integration and stick with the git commandline, unless you are a licensed user and you are OK with just Katalon support.