Katalon report uploader creates empty test suite executions?

Using katalon-report-uploader-0.0.3.jar and experiencing a huge amount of empty testrun reports created in the web interface.

  • Tried to clear the directory, run the test suite again, same result
  • Tried to run test suite collection, same result
  • Tried to run one by one, same result

Now every time I need to go and manually delete the empty ones from the web.
You can see the issue here: Katalon TestOps


1 Like

Sorry for this issue. There is an issue with importing reports last week. If you want we will re-import empty reports for you. Also, we will add a function to allow users to rerun the import process in the future.

Thanks for your reply!
The issue is not that reports don’t show up, they get imported properly, but as it seems the same amount of empty reports gets created.

1 Like

Any update on this one? Seems like a bug in the uploader.

Hi @gyula.csontos,
Just to update, we will release a new KA version next week that will fix this issue. Thank you for reporting.
Have a nice weekend.

1 Like

I just want to reply stating that I am getting empty suite names now. I have the latest version (6.1.0). This was working last week, but today it does now.

I have the similar problem but my results are completely empty…Version: 6.1.1

I’m seeing the same thing as Uros_Kocevar - the issue seems to have been introduced sometime after 7am EST today (4/9/2019).

Update: the empty test data appears to now just be for the last couple of tests run - I have a test suite that runs hourly, and only the latest two runs show as empty, as they age they become populated as expected.

1 Like

I came here to report the same thing. I noticed yesterday I had empty reports. Then today I saw those reports now had results in them. It looks like there is a delay or the katalon team is reimporting the reports to get them to show. Either way it looks like they are working on it.

1 Like

Hi @tim.coffey, @Uros_Kocevar, @Jason_Roberts and @Eric_Montou,

Thank you all for reporting the issue. There is a latency in populating test data onto your KA reports as we now have a larger volume of test logs. We’re now working on a solution for enhance the speed of parsing data for KA.


I came back to state that they eventually displayed correctly, so latency does seem to be the issue. Thanks Mia.

1 Like

The latency issue seems to be getting worse - currently my reports show blank for the last 36 hours.

Any ETA on when this will get fixed?

1 Like

We will release a new version in two days with performance improvements. Sorry for the issue - the usage is rising faster than expected.

1 Like

Even I am facing the same issue.Hope to get a fix for this soon.

I am also facing the same issue,pls fix for this as soon as possible.

Creates Empty test suite results ,graphs etc.

Hi @mia.ferguson is this issue solved? I also facing the same thing where i not able to see my test case result and report in katalon analytics when want to debug

New version has been deployed. It might take several hours to import all pending reports - after that new reports will be imported quickly.


@devalex88 - yep your teams update appears to resolved the issue for us. Thank you so much!!! :star2:

I’m still seeing latency - no reports available for the last three days.

I do like the look & feel of the new Analytics ui, though.

1 Like