Katalon project very slow to open on startup of Katalon --- VPN?

Please share the .log file that Katalon Studio wrote while you experienced slow initialization.

  • Windows logs folder:
    <Katalon Studio folder>\config\.metadata\.log
  • macOS logs folder: file:///Applications/Katalon%20Studio.app/Contents/MacOS/config/.metadata/.plugins/org.eclipse.ui.workbench/log

To make the .log file concise, please follow the steps

  1. stop Katalon Studiio
  2. delete the .log fiile
  3. restart Katalon Studio and open the project … you need to wait for 15 minutes?
  4. stop KS again
  5. share the file to us.

I attached my .log file here just for your reference — I experience no slowness at all. Do you find any remarkable difference in your .log file? — eg. Java Stacktraces printed repeatedly, etc.
my.log.text.zip (1.2 KB)

Could you share the <projectDir>/.classpath file of your problem project?

.log.zip (2.8 KB)

.classpath.zip (2.3 KB)

In the .log file, I found several points to note:

katalon.versionNumber=7.9.1
katalon.buildNumber=208
!SESSION 2021-03-14 16:31:39.648 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_181
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_CA
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -data @noDefault

You are using Katalon Studio ver7.9.1 on Windows

!ENTRY org.eclipse.egit.ui 2 0 2021-03-14 16:32:07.413
!MESSAGE Warning: The environment variable HOME is not set. The following directory will be used to store the Git
user global configuration and to define the default location to store repositories: 'P:\'. If this is
not correct please set the HOME environment variable and restart Eclipse. Otherwise Git for Windows and
EGit might behave differently since they see different configuration options.
This warning can be switched off on the Team > Git > Confirmations and Warnings preference page.

…(17 minutes passed)

!ENTRY org.eclipse.e4.ui.workbench 1 0 2021-03-14 16:49:30.192
!MESSAGE Reloading plugins.

…(3minutes passed)

!ENTRY org.eclipse.ui 4 4 2021-03-14 16:52:35.526
!MESSAGE To avoid deadlock while executing Display.syncExec() with argument: com.kms.katalon.composer.project.handlers.ProjectSessionHandler$3$$Lambda$620/193889212@520acd07, thread Worker-8: Restoring Previous Session will interrupt UI thread.
!SUBENTRY 1 org.eclipse.ui 4 4 2021-03-14 16:52:35.527
!MESSAGE Worker-8: Restoring Previous Session thread is an instance of Worker or owns an ILock
!STACK 0
java.lang.IllegalStateException: Call stack for thread Worker-8: Restoring Previous Session
	at sun.management.ThreadImpl.dumpThreads0(Native Method)

…(Many other Java Stacktraces followed)

In the .classpath file I found

<classpathentry kind="lib"
     path="C:/Users/mgrandillo/Downloads/Katalon_Studio_Windows_64-7.7.2/Katalon_Studio_Windows_64-7.7.2/plugins/com.kms.katalon.core_1.0.0.202101290615.jar" sourcepath="C:/Users/mgrandillo/Downloads/Katalon_Studio_Windows_64-7.7.2/Katalon_Studio_Windows_64-7.7.2/configuration/resources/source/com.kms.katalon.core/com.kms.katalon.core-sources.jar">

This line indicates that this .classpath file was created by Katalon Studio 7.7.2. On the other hand @mgrandillo is using Katalon Studio ver 7.9.1 now. The versions are mismatching. I guess that this discrepancy is the reason why he experiences the slow startup of KS project.


I experimented on my PC. I downloaded the .classpath file which @mgradillo provieded, overwrite it into one of my Katalon Project X. I started KS on my PC and opened my Project X, and watched how the <projectX>/.classpath file. Of course it was the same as the @mgradillo’s one, but after some seconds passed the file was overwritten by Katalon Studio. The Project X launched successfully. I checked the .classpath file and found it was new — compliant to KS v7.9.1.

This experiment tells me that the .classpath file will be silently/automatically overwritten by Katalon Studio at project startup. Therefore it is safe to delete the .classpath file, as it will be restored anyway.


However, as noted, @mgrandillo is using KS 7.9.1 while in his project he has a .classpath file for KS7.7.2. I don’t see the reason why this could happen. Why his KS 7.9.1 does not overwrite the .classpath file in his project? Katalon Studio seems to have some fault here, is not robust enough.

->
@ThanhTo, @duyluong

Similar issue is here


@mgrandillo

Anyway, I would recommend you to try

  1. take a full backup of your project just in case of mistakes
  2. stop Katalon Studio
  3. delete <yourProject>/.classpath file — to avoid the version discrepancy found above
  4. delete <yourProject>/bin directory as well — to make the project clean
  5. restart Katalon Studio, open the project

and see


@mgrandillo

Do you use Git for your project? If yes, do you save .classpath file in the Git repository? I think you should NOT save the .classpath file. Just .gitignore it.

The following is the .gitignore file generated by KS 7.9.1:

.gradle

bin

Reports

Libs

output

!output/.gitkeep
build

.classpath

.project
2 Likes

The Libs folder should be also removed. This will force Katalon to properly re-index the entire project.
In fact all files mentioned by gitignore can be safely removed.

2 Likes

Hi everyone,

We have a significant update on this in v8.2.0 recently, now:

  • Improved loading time in Katalon Runtime Engine. Results from our benchmarking tests show: 2x faster for big projects, 1.5x faster for small and medium projects.
  • Improved responsiveness and loading time for big projects in Katalon Studio. Results from our benchmarking tests show: renaming/opening test cases 2x faster, moving test cases 1.5x faster.
  • Reduced 12% memory consumption on average of Katalon Studio when opening/executing tests.
  • Reduced 30% memory consumption on average of Katalon Runtime Engine for long execution sessions.

Please first check out the release note and click here to download if you want to try out version 8.2.0 (stable).

I still have the same slowness issue. I am using KS 8.2 version and it takes close to 15mins for my project to load. And also again to switch from Test case to Keywords it again takes 10-15mins. Any help here is highly appreciated.
Thanks in Advance!!

Hi @Aruna, as mentioned above do the following:

  • Log out of Katalon.
  • Make a backup of <yourProject> (should anything go wrong).
  • delete <yourProject>\.classpath file
  • delete <yourProject>\bin directory to cleanup your project
  • Restart Katalon and open you project.

Hopefully this will help improve your project load time.

Hi @Dave_Evers,
Tried everything but no luck, even deleted lib folder as well…

try deleting <yourProject>/.cache directory as well.

Hi @kazurayam,

Tried that as well, and also tried re-installing KS as well.
Thanks…

Please show the .log file where you may find some error messages.

Katalon Studio logs

  • Windows logs folder: \config.metadata.log

  • macOS logs folder: file:///Applications/Katalon%20Studio.app/Contents/MacOS/config/.metadata/log

Hi @kazurayam,

Thanks for the prompt reply. Attached .log file from MAC.katalon.log (192.6 KB)

!SUBENTRY 1 org.eclipse.jface 2 0 2021-12-12 18:53:38.257

... (14 minutes passed)
	

!ENTRY org.eclipse.e4.ui.workbench 1 0 2021-12-12 19:07:49.188
!MESSAGE Reloading plugins.

!ENTRY org.eclipse.e4.ui.workbench 4 0 2021-12-12 19:07:49.542
!MESSAGE 
!STACK 0
java.lang.NullPointerException
	at com.kms.katalon.entity.report.ReportEntity.getLocation(ReportEntity.java:36)
	at com.kms.katalon.entity.file.FileEntity.getId(FileEntity.java:18)
	at com.kms.katalon.controller.ReportController.reloadReport(ReportController.java:257)
	at com.kms.katalon.composer.components.impl.tree.ReportTreeEntity.getObject(ReportTreeEntity.java:39)
	at com.kms.katalon.composer.components.impl.tree.ReportTreeEntity.getObject(ReportTreeEntity.java:1)
	at com.kms.katalon.composer.project.handlers.ProjectSessionHandler$3.run(ProjectSessionHandler.java:164)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

!ENTRY org.eclipse.e4.ui.workbench 4 0 2021-12-12 19:07:49.548
!MESSAGE 
!STACK 0
java.lang.IllegalStateException: this writer hit an unrecoverable error; cannot commit
	at org.apache.lucene.index.IndexWriter.prepareCommitInternal(IndexWriter.java:3177)
	at org.apache.lucene.index.IndexWriter.commitInternal(IndexWriter.java:3445)
	at org.apache.lucene.index.IndexWriter.shutdown(IndexWriter.java:1046)
	at org.apache.lucene.index.IndexWriter.close(IndexWriter.java:1087)
	at com.kms.katalon.composer.components.impl.util.EntityIndexingUtil.doIndex(EntityIndexingUtil.java:182)
	at com.kms.katalon.composer.project.handlers.IndexProjectHandler$1.run(IndexProjectHandler.java:42)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
Caused by: java.lang.IllegalStateException: unexpected docvalues type NONE for field 'id' (expected=SORTED). Re-index with correct docvalues type.
	at org.apache.lucene.index.DocValues.checkField(DocValues.java:317)
	at org.apache.lucene.index.DocValues.getSorted(DocValues.java:369)
	at org.apache.lucene.index.Sorter.getOrWrapSorted(Sorter.java:235)
	at org.apache.lucene.index.MultiSorter.getComparableProviders(MultiSorter.java:165)
	at org.apache.lucene.index.MultiSorter.sort(MultiSorter.java:47)
	at org.apache.lucene.index.MergeState.buildDocMaps(MergeState.java:196)
	at org.apache.lucene.index.MergeState.<init>(MergeState.java:148)
	at org.apache.lucene.index.SegmentMerger.<init>(SegmentMerger.java:60)
	at org.apache.lucene.index.IndexWriter.mergeMiddle(IndexWriter.java:4452)
	at org.apache.lucene.index.IndexWriter.merge(IndexWriter.java:4057)
	at org.apache.lucene.index.ConcurrentMergeScheduler.doMerge(ConcurrentMergeScheduler.java:625)
	at org.apache.lucene.index.ConcurrentMergeScheduler$MergeThread.run(ConcurrentMergeScheduler.java:662)

This makes me guess your Katalon Studio installation is somehow corrupted.

Please try removing the Katalon Studio completely. Clear it off the disk.

And download the *.dmg file fresh, and install it again.

Hi @kazurayam,
Tried deleting everything and doing a fresh install of Katalon. I noticed the same problem again while loading my project. As another try I tried to install Katalon on my Windows VM Ware and load the same project there. In Windows I didn’t notice the slowness. But the slowness is happening only on MAC. Any help on this?? In Windows I can’t have the VPN running so I can’t run the scripts from there, with that I need to fix the issue on my MAC. Any help/inputs on this is highly appreciated.
Thanks in Advance!!

I use Mac as well, and have never experienced such slowness. I believe your problem is specific to your environment.

Which version of macOS are you on?

In which directory do you install KS? In the /Applications directory?

Do you use *.dmg file to install?

Is your Mac connected to the Internet? or through Proxy?

Do you have your project “Test Ops integration” enabled? If yes, try disabling it.

Try toolbar File > clean up, and stop KS and restart KS.

How many subfolders under the “Reports” directory do you have? If many, remove them.

Hi @kazurayam,
I am currently using macOS Monterey Version 12.0.1
It is currently located in Applications folder.
Yes *.dmg file is used to install
It is through Proxy.
Test Ops is not integrated.
Tried doing Cleanup and Restarted, but no luck…
Not many Subfolders under Reports…Will clear them frequently.

@Aruna

try downgrading to Katalo Studio v7.9.1

You can download it at

https://github.com/katalon-studio/katalon-studio/releases/tag/v7.9.1

Why? Katalon Studio v8.x included several changes internally. That caused several performance problems but they have fixed them. For example, see


If you find v7.9.x is better, your case may suggest KS v8.2.x has one more problem unresolved.

In that case, you should talk to Katalon Team and request their investigation. If you are using a paid license, you should submit an official support ticket. They would ask you to provide a zip of your katalon project. Let them have it and wait.