Katalon mobile object spy is unable to parse elements from UIDatePicker with an "inline" style

Following is my inline time picker for an iOS app.
When I am trying to capture object katalon can see till Time.
However during execution katalon is failing to see the object.
I have tried with all elements locators for that field. Is there any possible solution to solve this issue. I want to tap and see the value in that field.

@duyluong any solution to deal with this new inline time picker on iOS?**


In the Object Properties tab of Mobile Object Spy, you can see the Highlight button. Click on it to let KS verify anh highlight the object by using the selected Locator Strategy and Locator.
If the current collector is incorrect, you can manually change to another Locator Strategy then click Generate and highlight again.

@duyluong Thank you for the quick response. I tried with all the locator strategy. But Katalon has no clue that there is further more fields in there under Time. If you have a look at my first image from development screen, it can be seen that there is a text field to input values, then there is a time wheel for picking hour and minute. But Katalon is not picking elements after Time filed which is an outer container for all the editable fields. I think this is a new implementation in iOS for inline time picker.

On my second image you can see the Time field is highlighted by Katalon, but the further field under that Time field is not shown by Katalon. Also, during execution, the time field itself is not picked up by Katalon using any of the native strategies available in Katalon. I tried all of them and tried dynamic xpath as well. But still Katalon fails to see the object.