Katalon import not recognized

when I add code related to MQQueueConnectionFactory the below imports changes and become underlined. The same MQ code works fine in eclipse.

import static com.kms.katalon.core.checkpoint.CheckpointFactory.findCheckpoint
import static com.kms.katalon.core.testcase.TestCaseFactory.findTestCase
import static com.kms.katalon.core.testdata.TestDataFactory.findTestData
import static com.kms.katalon.core.testobject.ObjectRepository.findTestObject

I put my MQ code in public static void main(String[] args) {}

but when I remove main () method and just put the code with try {} and catch {} , all MQ related methods become underlined . for ex: this become underlined and “setHostName” is not recognized.

mqQueueConnectionFactory.setHostName

Can someone help , please?

Did you import related MQ classes in your script?

Yes, I have imported all MQ classes and added jar (maven dependencies) in external libraries under settings . Am I missing anything else?

What error do you get?
Did you try to press Ctrl + Shift + O to add required imports?

trying ctr+shift+o resolved some dependencies. There is still underlined code. and pressing ctr+shift+o is not opening the dependencies dialog box that it opened earlier.

See, my main issue is - when I worked with maven and added dependencies for ibm-mq , it downloaded everything and he code worked fine. Now , as I mentioned I added the jar but still some dependencies are remaining. Is there any way in katalon that we can work like maven. Or directly work with maven or some other dependency management tool, so we don’t have to worry about adding jars and in that process missing jars. Thank you.